How can I Configure maximumFileSizeToCacheInBytes to change its limit

Hello I am using github actions for building and since yesterday I am getting the following error

/static/js/main.983f29d8.js is 6.38 MB, and won't be precached. Configure maximumFileSizeToCacheInBytes to change this limit.

I have two questions:

  1. how can I change maximumFileSizeToCacheInBytes for a larger size ?
  2. Why the size of that file in github is way larger than the one locally after making a build (1.6 MB locally, 6.3 MB in CI server) ?

It seems Github isn’t applying compression to the build. It might be helpful to share the YML for the action that you are using to build.

I use GitHub Actions a lot, and I’ve found I have to set max-old-space-size to get it to work reliably:

  - name: Build everything Ionic.
      # Prevent running out of memory by setting RAM to 4GB.
      NODE_OPTIONS: '--max-old-space-size=4096'
    run: npm run build-prod-app

Sure , there you go

# This file was auto-generated by the Firebase CLI

name: build on PR
"on": pull_request
    if: "${{ github.event.pull_request.head.repo.full_name == github.repository }}"
    runs-on: ubuntu-latest
      - uses: actions/checkout@v2
      - run: yarn install && yarn build --production