Has-bouncing="true" not working on android ionic


#1

I don’t know if the problem comes from ionic or cordova,
but when my bower.json file is configured as follows:

“devDependencies”: {
" ionic": “driftyco/ionic-bower#1.2.0”,
“ngCordova”: “~0.1.23-alpha”
},

has-bounce on real device doesn’t work. Although if I change it to:

“devDependencies”: {
“ionic”: “driftyco/ionic-bower#1.1.0”,
“ngCordova”: “~0.1.20-alpha”
},

And run gulp install it works fine.

Is it a bug or the way to set has-bouncing has changed?
I tested it on an android 4.4 device.


#2

I don’t know this for certain, but I suspect it has to do with Ionic implementing native scrolling by default now. Maybe with native scrolling, you can’t use has-bouncing?

I’d disable native scrolling and try has-bouncing to see if that is the problem.


#3

Thank you for answering.
How can I do that?


#4

See overflow-scroll in the ion-content docs : http://ionicframework.com/docs/api/directive/ionContent/

Also : http://ionicframework.com/docs/api/provider/$ionicConfigProvider/ scrolling.jsScrolling(value)


#5

is this confirmed? does native scrolling on android not work together with has-bouncing=true ?


#6

Thanks! It’s worked!