Has-bouncing="false" does not prevent bouncing on iOS

The has-bouncing=“false” attribute is not working for me on iOS, whether I put it on ion-content or ion-scroll, or anything. My structure is like (in Jade style):


with ion-items in the ion-list. I also have these settings in my config.xml:

  <preference name="webviewbounce" value="false" />
  <preference name="UIWebViewBounce" value="false" />
  <preference name="DisallowOverscroll" value="true" />

I’ve tried adding overflow-scroll=“true” but that hasn’t had any effect . Is there anything else that needs to be done to disable scroll bouncing?

1 Like

Same here. Did you find a solution?

Nope. I gave up and learned to accept it :disappointed:

@max Same issue here. has-bouncing='false' not working. Any solution?

me too. what is happening here ?

Seem like has-bouncing="false" not work when scroll="false". Any ideas ?

Hi guys,

Same issue here. No way to make has-bounce working.

Try to add this to the ion-content:

<ion-content (touchstart)="disableBouncing($event)">

And add the blockBounce function to the .ts file:


Does it actually work?

The above initially did seem to work for me… except if I have a select open - then the view underneath seems to get the bounce back (while the select popup is open). Also it interfered with some other events (eg my click event in the C3 charts library)

The best fix I found here, ie just add

<ion-content no-bounce>