Googleplus plugin not installed error in dev build


#1

I have googleplus plugin installed in my project & working fine if I run ionic run android --device.
Problem is when I run ionic deploy & run the app from Ionic View app, I receive plugin_not_installed error in console on google login. Same with ionic build package. What can be the cause? Why it is good in ionic run but not in deploy or package?

Ionic info:
Cordova CLI: 6.5.0
Ionic Framework Version: 3.0.1
Ionic CLI Version: 2.2.2
Ionic App Lib Version: 2.2.1
Ionic App Scripts Version: 1.3.0
ios-deploy version: Not installed
ios-sim version: Not installed
OS: macOS Sierra
Node Version: v6.10.2
Xcode version: Xcode 8.3.1 Build version 8E1000a


#2

I don’t see it listed in here. Can you just build locally?


#3

OK. I created a debug build. And everything working fine. But why not in prod build? Why it tells plugin_not_installed.


#4

What is the command to create this “prod build”?


#5

ionic build package --profile “profileName”


#6

That is just a normal “dev” or “debug” build on Ionic Package.
If you want to do a production, or “release” build, you have to add --release to the command (additionally to selecting a production profile/certificate): https://docs.ionic.io/services/package/#release-builds


#7

How it is related to plugins? If plugin is working in debug build, why it shows plugin_not_installed in build generated by ionic build package?

  • I did ionic build android & used generated apk. Working fine.

  • I did ionic build package --profile “profileName” & downloaded apk from dashboard. App is running good. But when I tried google login, plugin_not_installed message in console.

What I am missing?


#8

I don’t know. You asked “why not in prod build”. Then you posted the command you used, and nothing about it is a “prod build”. So I am still trying to understand what you are doing and what you are expecting. It’s kind of important to use the correct words when we are talking about dev, prod, release, production, debug and so on because otherwise we talk about different things.

Also, the command you posted doesn’t even contain “android” or “ios”, so this can not really be the command you were running.


#9

Your comment making my day worst. I have to distribute a build & here you are telling me how to generate prod & dev builds without going through my main question.


#10

Well, I can’t help you if you are not even posting the correct commands you are executing. I suggest you just start a new topic, include all the necessary information and make sure you are asking a consistent question.


#11

Sorry for that comment. I was really frustrated that time. I’ll post new question if I am not able to solve this problem myself. Thanks.