Getting Started ... Going Nowhere


#1

I was wildly excited when I saw this framework, so I dived straight into the short Getting Started - the one with 3 simple steps that ends “That’s it!”. It failed to add either android or ios platforms. I’ve tried on 2 flavours of Linux and 3 of Windows, all on different hardware, and I can’t get a single one to work, for the same or a variety of reasons. I use Node, npm and Angular professionally so I’m not entirely a noob, though this is my first venture into phonegap/cordova. What’s the deal, is it supposed to work as it says it does, or have I completely missed something?


#2

Hey,

I assume you installed the latest version of cordova, did you also install the Android and/or iOS portion:

Android
iOS

The sdk’s are needed for compilation.

If you complete the steps, does it work?


#3

Hi, thanks for the pointers.

I’ve been through the guide for setting everything up, including an AVD, and just tried the Getting Started bit again and yep it works fine.

I didn’t have the JDK or ant or Android SDK installed - “No sh** why it didn’t work then!” - yeah I get that with hindsight, but if you have a button front-and-center on your home page that says Get Started and shows 3 simple steps, then you pretty much assume it’s supposed to work as-is. If that button wasn’t there, I would have been more than happy just going through the setup in the docs, but I lost confidence to dig deeper because what seemed to be the simplest thing didn’t work already.

Anyway, enough said. It works and looks great, so I’m just glad to be on the road to something awesome :slight_smile:


#4

Good to hear ! Have an awesome time working with Ionic