Facebook Login Error

Hello, I’ve been using the cordova plugin https://github.com/jeduan/cordova-plugin-facebook4 and it’s working just fine… However, recently it doesn’t anymore, everytime I click the facebook login button it goes to facebook and just shows the following error message:

Login Error: There is an error in logging you into this application. Please try again later.

Anyone else currently experiencing this? I tried to start from a blank project from scratch, installed the dependencies and still I got the same error.

Here’s the straightforward login function:

loginAction() {
  this.fb.login(['public_profile', 'user_photos', 'email']).then((res: FacebookLoginResponse) => {
    console.log(res);
  }).catch((e) => {
    console.log('Error logging into Facebook', e);
  });
}

…and here’s the ionic info:

Ionic:

   ionic (Ionic CLI)  : 4.10.3 (C:\Users\Kenny\AppData\Roaming\npm\node_modules\ionic)
   Ionic Framework    : ionic-angular 3.9.5
   @ionic/app-scripts : 3.2.2

Cordova:

   cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
   Cordova Platforms     : android 7.1.4
   Cordova Plugins       : cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 4.0.1, (and 4 other plugins)

System:

   NodeJS : v10.15.1 (C:\Program Files\nodejs\node.exe)
   npm    : 6.4.1
   OS     : Windows 10

Thanks everyone :slight_smile:

did you add APP_ID when you add facebook plugin?

Yes, as I said, it was working last month…

did you solve the problem? I upgrade cordova-plugin-facebook4 but still same… :frowning:

When you’re trying to log in and receive this error message, usually it’s due to a setting in your account that prevents Tapas from connecting with Facebook.

First, make sure you are logged into Facebook in your browser or the Facebook app on your device. Then follow these steps:

  1. On Facebook, open the menu on the main navigation and select Settings
  2. Next, selects Apps
  3. Make sure the Apps, Websites, and Plugins section is Enabled
  4. Check if Tapas shows up on the list of apps to make sure there’s nothing unchecked that might be blocking the app from connecting
  • Facebook
  • Twitter
  • LinkedInWhen I am trying to log in and receive this error message, usually it’s due to a setting in my account that prevents Tapas from connecting with Facebook. Random video chat

I just found out that it’s working on an actual device :slight_smile:

Hello,

I have the same problem, but couldn’t you help me somehow?

Thanks.