Existing android studio to ionic


#1

Hi
I have an apps in the playstore which was built by android studio. Current version of the app is 14.
Now I want to create new update 15 by ionic and want to update in google playstore.

Plz help


#2

All you need to do is make sure the app id’s match and you sign the new app with the same signing cert as the first app.


#3

Thank you. signing cert- what does it mean ? Will u plz explain ?


#4

When you created your first app that you have in the Google Play store, it was digitally signed with a certificate. That same certificate must be used for any update to that app.

Chris


#5

Thnak you so much. But how can I use that. I have .jks file. But how can I use that? I have used Signerapk for signing and aligning file by using existing jks file. it build successfully. But when I uploaded, it show sha number is not correct. plz help me by giving detail.


#6

hi, i kind of have the opposite problem, i created my app using the browser, never emulated it with android or ios emulator, i had few problems with androis sdk so i said when i’ll finish the while thing i’ll try to emulated on android, now am struggling too many topics but i still can’t figure it out, can you please suggest me a way to see my app on my android? should i use some android editor or what?
Thank you :slight_smile:


#7

ionic run android

above command will help u to run in your android. what kind of sdk problem u r facing. I m not clear what of help u r actually looking.


#8

when i run : ionic build android i get no problems but once i run: ionic emulate android i get an error about the sdk, teling me i shloud use the 23 version, and i have the 24, it tells me to go to android management tools, i go there i choose the 23 version sdk and management tools, i unstall the whole thing then i get again the same error, i don’t know why, i wish i could fix this problem so i can emulate my app on android devices and see the results.
Thank you.


#9

change AndroidManifest.xml in platform/android
there change 23 to 24. hope it will work


#10

i did it but i’ve got this error:
module.js:341
throw err;
^

Error: Cannot find module 'umask’
at Function.Module._resolveFilename (module.js:339:15)
at Function.Module._load (module.js:290:25)
at Module.require (module.js:367:17)
at require (internal/module.js:16:19)
at Object. (c:\Users\bouchra\AppData\Roaming\npm\node_modules\cor
dova\node_modules\npm\lib\utils\umask.js:1:75)
at Module._compile (module.js:413:34)
at Object.Module._extensions…js (module.js:422:10)
at Module.load (module.js:357:32)
at Function.Module._load (module.js:314:12)
at Module.require (module.js:367:17)


#11

I dont have any idea