Error installing apk, need some help (first timer)


#1

Hey guys,

I am new to the Ionic framework but jumped on it from a more naked phonegap experience as I loved the way it filled the UI void (tried the Onsen UI, liked it at first, then found Monaca which allowed editing in the cloud and LOVED IT, until I realized the cloud based services it made you use in your app and left instantly).

I built a basic layout and structure of my new app and it works perfectly in the broswer with ionic serve

I attempted to compile a version to try on my phone following these instructions: http://ionicframework.com/docs/guide/publishing.html

the apk tries to install, i get the little premission box (this apps wants access to…etc etc), it tries to install then fails with no specific error, just says install failed…

now obviously the tutorial I am following is for google play store, since I am not doing that, should I have been adjusting the compile approach at all? perhaps the signing stage? something I should not be doing or something I should be?

Thanks for any help you can offer,

(also if any admins see this, can I get a creator invite? looks sharp!)


#2

Just a couple of nonspecific things: are you targeting the correct API level, or do you need to relax your requirements a bit? do you get more informative messages when you try to install the app using adb?


#3

Hi @BioPerl,

In your Android device’s security settings make sure you are allowing installations from unknown sources. This could prevent an application from installing. If you signed your application incorrectly, you may also be experiencing problems. Does a debug build work?

ionic build android
adb install -r platforms/android/ant-build/YOURAPP-debug.apk

If you’re getting errors on run-time, you may check out what @inportb mentioned.

Regards,


#4

If you’re getting errors at runtime, then adb logcat would be the debugging tool to use. It sounds like you do have unknown sources enabled because you’re seeing the permissions screen, but check it out to be sure.


#5

thanks guys for both suggestions. I do indeed have allow from unknown sources enabled, as previously mentioned it was a requirement to get as far as I did.

I will give the debug tool a go, I will also look at following the steps again with a demo app in ionic to rule out any device specific issues and not ionic framework issues that might be going on.

will post back tomorrow with the conclusion from my investigation

again, I thank you both for your help and suggestions!


#6

Same error here…

any news about that BioPerl?