ERROR in tsconfig.json with fresh project

I ran:

ionic start, selected Vue

Then I ran

ionic cap add android

Then I ran ionic serve and I receive:

[vue-cli-service] App running at:
[vue-cli-service] - Local: http://localhost:8100/
[vue-cli-service] - Network: http://10.9.1.197:8100/
[vue-cli-service] Note that the development build is not optimized.
[vue-cli-service] To create a production build, run npm run build.
[INFO] Browser window opened to http://localhost:8100!

[vue-cli-service] ERROR in tsconfig.json
[vue-cli-service] TS5083: Cannot read file ‘C:\repos\ionicNetworkTest2\tsconfig.json’.

Seems to be a problem using ionic-cli with windows PowerShell. Everything worked with Ubuntu 20.04…

I guess WSL2/Windows is not fully supported yet?

This is not the exact issue you are running into, but it looks like Vue 3 has some issues with WSL2 at the moment: hot reload not working on WSL2 · Issue #4421 · vuejs/vue-cli · GitHub The issue you are running into may be related.

You could try creating a Vue 3 starter app without Ionic Vue and see if you can reproduce the issue there: https://v3.vuejs.org/

1 Like

I changed the directory name to all lower case and it seemed to progress on Windows. I will test with a pure Vue JS project too.

1 Like

Created a Vue 3 test project with vue create vue-test and selected Vue 3. it worked fine, but it didn’t generate a tsconfig.json. npm run serve launched the website perfectly and was able to view the starter Vue webpage. All of this worked on powershell/Windows too