Cannot read file src\tsconfig.json


#1

Hi all,

When I run ionic serve in a project I get:

[INFO] Starting app-scripts server: --address 0.0.0.0 --port 8100 --livereload-port 35729 --dev-logger-port 53703 - Ctrl+C to cancel
[10:01:58]  watch started ...
[10:01:58]  build dev started ...
Error: tsconfig: Cannot read file 'C:\Users\Thijmen\Desktop\ionic-old\src\tsconfig.json': ENOENT: no such file or directory, open 'C:\Users\Thijmen\Desktop\ionic-old\src\tsconfig.json'.
    at BuildError.Error (native)
    at new BuildError (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\util\errors.js:16:28)
    at getTsConfig (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\transpile.js:296:15)
    at Object.<anonymous> (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\transpile.js:281:46)
    at step (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\transpile.js:32:23)
    at Object.next (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\transpile.js:13:53)
    at C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\transpile.js:7:71
    at __awaiter (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\transpile.js:3:12)
    at Object.getTsConfigAsync (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\transpile.js:278:12)
    at validateRequiredFilesExist (C:\Users\Thijmen\Desktop\ionic-old\node_modules\@ionic\app-scripts\dist\build.js:53:21)

I’ve never got an tsconfig.json inside my SRC folder.
I dont know why this error is popping up.

Thanks in advance


#2

I have the same issue!
Just updated ionic and getting the same error. There is no tsconfig.json in my project file.

I am building an ionic v1 app.
If I find a fix, I will post. You might post a fix too if you find one.

Hers is my env info if you want to cross check

    @ionic/cli-utils  : 1.12.0
    ionic (Ionic CLI) : 3.12.0

global packages:

    cordova (Cordova CLI) : 7.0.1

local packages:

    @ionic/app-scripts : 3.0.0
    Cordova Platforms  : android 6.2.3 ios 4.4.0
    Ionic Framework    : ionic-angular 3.7.1

System:

    Node : v6.11.0
    npm  : 5.4.2
    OS   : Windows 10

Misc:

    backend : pro```

Thanks

#4

It’s because you try to build a Ionic V1 app with Ionic V3. It will never work.

EDIT : To help you, most V2 code is compatible with V1, at least till middle V2 Ionic, after it’s purely V3.
I mean by that you updated ionic framework in your CLI, but this as changed a lot now for many ways of coding (ways of writing functions, types, classes and providers). So it can’t work.

Regards,


#5

Thanks for the response.
I would of though ionic is backwards compatible. I only updated because it kept prompting me every time I executed ionic serve or build. I didn’t think it would break my environment!

I had to rebuild a new project folder:

ionic start blank myApp --type=ionic1

I copied the config.xml, bower.json, package.json and index.html/www.
Removed node_modeules and done npm install and bower install.

In the ionic.config.json, I had to change:

“type”: “ionic-angular”

to

“type”: “ionic1”,

I can now run ionic_serve again.
Its back up and running :slight_smile:


#6

Ionic uses semantic versioning so whenever there’s a new major version it means there’s a breaking change. In the case of Ionic 1 to Ionic 2+ it’s a drastic change.


#7

Thanks Guys. Good to know.
Hopefully someone can use this thread if they get caught like me.

Wasted few hours fixing it :frowning:


#8

And no unfortunately, Ionic is not backwards compatible with ionic 1, it’s improving now since 2 & 3 codebase (what i mean with Ionic Framework 2 & 3). Ionic 1 is a totally different way of coding the app, so, the devs chose (for a good reason) to that being not backwards compatible.