Tried installing wp8 platform, now ionic 2 ts does not work anymore... :(


#1

I was using Ionic V2 flawless but I had tried to do:
ionic platform add wp8

Now I don’t know the reason, my ionic stoped working…
I already tried to remove EVERYTHING including node and reinstalling everything back but the problem still persist…

this is what I have here:

C:\Users\user\Dropbox\ionic>ionic start teste --ts --v2

One awesome Ionic app coming right up…

Downloading: https://github.com/driftyco/ionic2-app-base/archive/typescript.zip
Downloading: https://github.com/driftyco/ionic2-starter-tabs/archive/typescript.
zip
Installing Node Modules

♬ ♫ ♬ ♫ Your Ionic app is ready to go! ♬ ♫ ♬ ♫

Make sure to cd into your new app directory:
cd teste

To run your app in the browser (great for initial development):
ionic serve

To run on iOS:
ionic run ios

To run on Android:
ionic run android

To test your app on a device easily, try Ionic View:
http://view.ionic.io

New! Add push notifications, update your app remotely, and package iOS and Andro
id apps with the Ionic Platform!
https://apps.ionic.io/signup

New to Ionic? Get started here: http://ionicframework.com/docs/v2/getting-starte
d

C:\Users\user\Dropbox\ionic>cd teste

C:\Users\user\Dropbox\ionic\teste>ionic serve

∆ Compiling and bundling with Webpack…
√ Using your webpack.config.js file

∆ Compiling Sass to CSS
√ Matching patterns: app/app.+(ios|md).scss

∆ Copying fonts
√ Matching patterns: node_modules/ionic-framework/fonts/**/*.ttf

∆ Copying HTML
√ Matching patterns: app/**/*.html

√ HTML copied to www/build

C:/Users/user/Dropbox (Personal)/ionic/teste/app/app.ts
> Module parse failed: C:\Users\user\Dropbox (Personal)\ionic\teste\app\ app.ts Line 1: Unexpected token
> You may need an appropriate loader to handle this file type.
| import {App, Platform} from ‘ionic-framework/ionic’;
| import {Page1} from ‘./pages/page1/page1’;
| import {Page2} from ‘./pages/page2/page2’;
@ multi main (CLI v2.0.0-beta.15)

Your system information:

Cordova CLI: 5.4.1
Ionic Version: 2.0.0-alpha.45
Ionic CLI Version: 2.0.0-beta.15
Ionic App Lib Version: 2.0.0-beta.8
OS:
Node Version: v5.3.0

I also have installed windows phone 8 sdk, should this be the problem?

When I’d installed the node again, the OS: information was gone from the system info too…

Can anyone give me some light in the end of tunnel?

Please Help!


Ionic Serve error with Tutorial Starter --v2 --ts
#2

if I compile with tsc it works… but not automatically:

tsc --watch -m commonjs -t es5 --emitDecoratorMetadata app/app.ts

it creates js files and works but it is not good b/c i need to run every time before serve or build or anything else


#3

I have the same exact issue, and know what is causing it: the fact that you are using the .ts extension. When I use app.js (and all .js extensions) then my app runs sound.

However, I cannot find a way to allow ionic to compile .ts files properly. This is very important, mainly to my IDE (webstorm) and being able to show errors/warnings etc. Typescript compiler doesn’t work and there are red squigglys everywhere because webstorm is thinking it is javascript, not typescript.

Any ideas on how to get Ionic to play well with .ts files?