Does Ionic Capacitor support android 5 and android 6?

Please describe the question in detail and share your code, configuration, and other relevant info.

I have created a small camera APP with Ionic Capacitor. I am not able to run this APP on Android 5 o6 . I could run from android 7+. I just want to know whether Capacitor really support on android 5 and 6?

answered Does Ionic Capacitor support android 5 and android 6? · Discussion #4204 · ionic-team/capacitor · GitHub

They are supported as long as the Android WebView version is 50 or later, but the simulators use an older version that can’t be updated, so you should test on real devices.

@jcesarmobile Thank you for the answer. I tried with real device. Android WebView I installed from https://www.apkmirror.com/. Version : 59.0.3071.125. Still my APP stuck with white screen and the error ‘Unexpected strict mode reserved word’. How can we solve this error?

Hard to tell with that little information, but that’s a javascript error telling you that you are using a reserved word. Is it telling you which one is the reserved word?

@jcesarmobile


No. I use Ionic framework with vuejs.
More Info :
Ionic:

Ionic CLI : 6.12.4 (C:\Users\sheeja_seu\AppData\Roaming\npm\node_modules@ionic\cli)
Ionic Framework : @ionic/vue 5.5.4

Capacitor:

Capacitor CLI : 2.4.6
@capacitor/core : 2.4.6

Utility:

cordova-res (update available: 0.15.3) : 0.15.2
native-run : 1.3.0

System:

NodeJS : v10.21.0 (C:\Program Files\nodejs\node.exe)
npm : 6.14.4
OS : Windows 10

Package.Json

{

“name”: “Curves_TabletAPP”,

“version”: “0.0.1”,

“private”: true,

“scripts”: {

"serve": "vue-cli-service serve",

"build": "vue-cli-service build",

"test:unit": "vue-cli-service test:unit",

"test:e2e": "vue-cli-service test:e2e",

"lint": "vue-cli-service lint"

},

“dependencies”: {

"@capacitor/android": "^2.4.6",

"@capacitor/core": "^2.4.6",

"@ionic/vue": "^5.4.0",

"@ionic/vue-router": "^5.4.0",

"core-js": "^3.6.5",

"es3-safe-recast": "^3.0.0",

"vue": "^3.0.0-0",

"vue-router": "^4.0.0-0",

"vuex": "^4.0.0"

},

“devDependencies”: {

"@capacitor/cli": "^2.4.6",

"@vue/cli-plugin-babel": "~4.5.0",

"@vue/cli-plugin-e2e-cypress": "~4.5.0",

"@vue/cli-plugin-eslint": "~4.5.0",

"@vue/cli-plugin-router": "~4.5.0",

"@vue/cli-plugin-unit-jest": "~4.5.0",

"@vue/cli-service": "4.5.11",

"@vue/compiler-sfc": "^3.0.0-0",

"@vue/test-utils": "^2.0.0-0",

"eslint": "^6.7.2",

"eslint-plugin-vue": "^7.0.0-0",

"vue-jest": "^5.0.0-0"

},

“description”: “Tablet APP For Curves”

}

If you need further information about any file, please let me know.
@jcesarmobile bug: Ionic 4 + Vue.js: Blank screen on Android 5.1 and Android 6.0 · Issue #19810 · ionic-team/ionic-framework · GitHub . This issue already reported and till date it is not solved

This is not truth, my ionic-vue app work only with webview 69.
Seems like need to use transpiler but I dont understand how work with.

Well, I’m talking about capacitor requirements, if vue requires a greater version then that constraint comes from vue, not from capacitor.

You likely will need to include certain polyfills. I recommend looking at this Vue guide for more information: Browser Compatibility | Vue CLI

2 Likes

@ghostriderus @jcesarmobile Android WebView 69 doesn’t work too

I’ve created two new ionic vue apps, with blank and sidemenu templates and both work fine on Capacitor with WebView 69. So your problem might come from another package. As ldebeasi told you, check that guide about polyfills.