Does cordova plugins support both ionic1 and ionic v2,3

I looking at a cordova plugin (cordova-plugin-firebase), my project satisfies the plugin in requirement. Just wanted to know if cordova plugins aren’t dependent on ionic versions? in otherwords will the plugin support both versions of ionic?

As far as I know, yes, cordova plugins aren’t dependent on ionic versions

A wrapper like ionic-native is on the other side dependent on the ionic version

1 Like