Dependencies between cordova plugins

During remove/add android platform, noticed this plugin dependencies.
This not single case, before had same between file and file-transfer plugins versions

One plugin ask to downgrade other one or force install.

Any ways to add “force” option to package.json or config.xml ?

Failed to install 'cordova-plugin-ionic': CordovaError: Version of installed plugin: "cordova-plugin-splashscreen@5.0.1" does not satisfy dependency plugin requirement "cordova-plugin-splashscreen@^4.0.0". Try --force to use installed plugin as dependency.

What version of ionic native do you have?

    "@ionic-native/app-version": "^4.5.3",
    "@ionic-native/camera": "^4.5.3",
    "@ionic-native/core": "^4.5.3",
    "@ionic-native/document-viewer": "^4.5.3",
    "@ionic-native/email-composer": "^4.5.3",
    "@ionic-native/file": "^4.5.3",
    "@ionic-native/geolocation": "^4.5.3",
    "@ionic-native/google-maps": "^4.5.3",
    "@ionic-native/image-resizer": "^4.5.3",
    "@ionic-native/in-app-browser": "^4.5.3",
    "@ionic-native/keyboard": "^4.5.3",
    "@ionic-native/network": "^4.5.3",
    "@ionic-native/onesignal": "^4.5.3",
    "@ionic-native/photo-viewer": "^4.5.3",
    "@ionic-native/screen-orientation": "^4.5.3",
    "@ionic-native/splash-screen": "^4.5.3",
    "@ionic-native/sqlite": "^4.5.3",
    "@ionic-native/status-bar": "^4.5.3",
    "@ionic-native/toast": "^4.5.3",
    "@ionic-native/transfer": "^3.14.0",

Having the same problem. Did you resolve this?
Thanks!

As far as I know, you should keep all ionic-native plugins on the same version. Is ionic-native/transfer the file download/upload plugin? If so, the newer version is now available at @ionic-native/file-transfer.

Or is there a special reason why you use that old version?

Here are the docs:

Mine has nothing to do with file-transfer. Just the same error.
Fixed by changing all native-plugins to same version.
Thanks!