Do anyone using Ionic with node.js v5?


#1

Hi,

Do anyone using Ionic with node.js v5?
I tried it, seem all cordova plugin do not install correctly with ionic 1.7.8 and node.js v5.

Do anyone got the same issue?

here is my env state:

Cordova CLI: 5.4.0
Ionic Version: 1.1.1
Ionic CLI Version: 1.7.8
Ionic App Lib Version: 0.6.4
ios-deploy version: 1.8.2
ios-sim version: 5.0.3
OS: Mac OS X El Capitan
Node Version: v5.0.0
Xcode version: Xcode 7.1.1 Build version 7B1005


#2

To be honest I’m not sure why, but there seems to be some errors using node.js v5 and ionic at the moment. I’ve had similar issues, but reverting back to Node.js 4.2.2 fixed the problems.

The Ionic docs do mention that it might be an issue using the latest Node.js versions: http://ionicframework.com/docs/ionic-cli-faq/#cli-commands1


#3

yep nodejs 5 doesnt work for me… so use 4.2.2 if you have node as a dependencies for other big frameworks like cordova, ionic etc. you should use the lts release 4.x


#4

Same here, experiencing problems with node v5 as well


#5

When I updated to node 5 I had the same issue with the plugins, so I just removed the platforms and add it again, and it’s working fine with me now.


#6

Update
Upgrading to Node v5.1.0 fixed the problem for me