Deviceready has not fired after 5 seconds

Using Ionic 1.0.0-beta.12 and CLI 1.2.4. I’m trying to test resume in the emulator for IOS and I keep getting this error.

deviceready has not fired after 5 seconds.
2 110550 log Channel not fired: onCordovaInfoReady

Here is some of my code. I get the error above and my resume broadcast never fires.

.run(function($ionicPlatform) {
$ionicPlatform.ready(function() {
// Hide the accessory bar by default (remove this to show the accessory bar above the keyboard
// for form inputs)
if(window.cordova && window.cordova.plugins.Keyboard) {
if(window.StatusBar) {
  // org.apache.cordova.statusbar required

document.addEventListener("resume", onResume, false);

function onResume(){


I got the error cleared up for deviceready but now on resume I get another error.

ReferenceError: Can’t find variable: appEvents,, Line: 23

I think I got this resolved.

Could you please share how you resolved the error giving the message
"deviceready has not fired after 5 seconds"

Maybe this might help

No luck fixing this by adding/removing the platform. I’ve seen in other places its related to the file plugin, but i’m using the file plugin here.
Any other folks having a similar problem and found a fix for it?

yes, I have the same issue and cannot find a solution that works.

Tried already the solution suggested by dragosh and also to remove/add with no luck…

Will post an update if I find a solution.

I have the same problem only if I run the app with browser-sync ionic run android -l -c -s

When I run the app normal ionic run the event fires just fine.
Also tried the suggested solution and it doesn’t work. I’m using crosswalk by the way.

I think the same probleme is discussed here:

Take a look at this, it fixed it just now when I had the same issue:

and Deviceready has not fired after 5 seconds

this link has changed to

Would you mind letting me know the way you resolved this issue?

Did you find the soluton.i removed platform and readded but no luck,i am not using network plugin also.i am checking on android@6.1.1

i have same but different problem.

deviceready has not fired after 5 seconds.
Channel not fired: onIonicProReady

only on ANDROID … IOS works fine

Using Angular 9.1.2 and Capacitor, deployed via android studio directly on the phone. Checkt via chrome://inspect and saw this error. cause of this error my keycloak service is not initialized