Ionic-angular-cordova-seed: deviceready has not fired after 5 seconds


#1

I get this message when serving the ios platform on the browser (cordova serve ios):

deviceready has not fired after 5 seconds. console-via-logger.js:173
Channel not fired: onCordovaInfoReady console-via-logger.js:173

This issue happens when creating a project with ionic command-line and when cloning from GitHub.


#2

If I understand your question right and you are viewing your cordova app with a desktop browser, then there will not be a devicereadyevent. In fact, the complete cordova.js framework is not available.

I’ve never used the cordova serve command (I actually just tried it and it fails). What I do is I run python -m SimpleHTTPServer 8000 from the www/ root. Maybe I’ve missed out on the cordova serve command all together and my answer shows my lack of knowledge!


#3

Ok, I was running the SimpleHTTPServer on port 8000 which prevented cordova from starting its own HTTP server on that port…

Anyway, it seems that running it this way, ther cordova.js framework is actually loaded and I get the same deviceready has not fired after 5 seconds message.

I’m not sure what the issue is. Do you get this message when you’re not using Ionic, just a plain Cordova project?


#4

Hi Daniel,

I just created a plain Cordova project and ran cordova serve on it. I do get the deviceready event here:

Received Event: deviceready

Tried inspecting both projects, but can’t seem to find any configuration difference on them.


#5

I am getting this same error today but I am trying to use the Camera plugin. Not sure if that has anything to do with it


#6

I’ve setup 2 projects side by side, one is the traditional cordova build. One is via the Ionic CLI.

The Cordova version does show device ready. This isn’t really a big deal because it is just a console.log statement. However, the Ionic app shows:

deviceready has not fired after 5 seconds. console-via-logger.js:173
Channel not fired: onCordovaInfoReady 

I’m wondering if we’re missing some functionality because of this.

I’ll reach out to the devs for some feedback on this.


Error "deviceready has not fired after 5 seconds" on latest version
#7

I was able to get around it by uninstalling cordova and re installing the newest version along with the latest version of android. Might have been that my sources were behind.


#8

Looks like I was removing the deviceready event listener after Ionic received the deviceready event. So this was probably why the event wasn’t being received by others.

Commit dc138b4fa3bea823b29b7627a6997bf1970cb3c0

Please let us know if this does not fix the issue, thanks!


#9

Hello, I have the same problem with the same message.
The $ionicPlatform.ready is never fired.

.run(function($ionicPlatform) {
  $ionicPlatform.ready(function() {
    console.log("hello")
    // Hide the accessory bar by default (remove this to show the accessory bar above the keyboard
    // for form inputs)
    if (window.cordova && window.cordova.plugins.Keyboard) {
      cordova.plugins.Keyboard.hideKeyboardAccessoryBar(true);
    }
    if (window.StatusBar) {
      // org.apache.cordova.statusbar required
      StatusBar.styleDefault();
    }
  });
})

#10

Exactly same problem here.


#11

I’ve got the same problem. Any solution ?