Deploy to Android phone show white page after upgrade to 2.0.0-rc.0


#1

I just upgrade an existing project to 2.0.0-rc.0, and make the changes accordingly.
The project is working well in browser when I run
ionic serve --c
but when I run
ionic run android
to deploy the app to my android phone, it show blank/white page.
Before I upgrade to 2.0.0-rc.0, the project is run well in browser and android environment. My android version is 5

Anybody experience the same issue? May I know how to fix this issue?


#2

Are you familiar with remote debugging? https://developers.google.com/web/tools/chrome-devtools/remote-debugging/

When my app doesn’t run I use remote inspector to see what exactly is wrong. With remote debugging you can also inspect all calls made. Saved me a lot of times :slight_smile:


#3

It only has problem to run in device as APP, but it working fine in browser.


#4

Still you can inspect the webview of your app


Property ... does not exist on type '{ [key: string]: AbstractControl; }'
#5

I just found the issue as I replace the content from main.dev.ts to main.prod.ts. If I am not replace that I will facing another form issue, which is related to

Property 'xxxx' does not exist on type '{ [key: string]: AbstractControl; }'.
.....

#6

I’ve had that problem as well :slight_smile: see Property ... does not exist on type ‘{ [key: string]: AbstractControl; }’