Ionic2 app show blank screen on android device (4.2.2) using run command and IonicView


#1

When I load the MyIonic2Project tutorial app on my 2 android(4.2.2 and 4.2.1) devices using “ionic run android”, cordova splash screen shows and after a few seconds, a blank screen shows and that’s all. The same thing appends using IonicView on the same devices (Crosswalk is installed).
With ionic1, loading the sidemenuproj on the 2 same devices work fine.
Thanks for helping me.
Sebastien

My system information:

Cordova CLI: 5.4.1
Gulp version: CLI version 3.9.0
Gulp local:
Ionic CLI Version: 2.0.0-beta.12
Ionic App Lib Version: 2.0.0-beta.6
ios-deploy version: Not installed
ios-sim version: 5.0.4
OS: Mac OS X El Capitan
Node Version: v5.1.0
Xcode version: Xcode 7.2 Build version 7C68


Livereload for android on device; the connection to the server was unsuccessful
#2

You should run command ionic server or ionic build before built to android to make webpack transpile es6 script to es5 script


#3

The same is happening here.
The white screen happened after installing the cordova package.
It works if i uninstall cordova.


#4

I have the same issue when deploying my app since I upgraded to the last beta the splash screens became white.
@arthurbalfredo What do you mean by uninstalling Cordova? How can you build against Android after?

Did anyone else find a solution to this?


#5

Same issue with ionic upload and using Ionic View. I hope that someone will help us.


#6

@kzr37 If i type

ionic run android 

without cordova, the app starts normaly on my android device.

I was forgetting to run

 ionic platform add android

After this i was able to build on the device without the blank screen.


#7

@arthurbalfredo
That doesn’t work for me, even after a “clean” startup project. The ionic commands give the same output as the the cordova command (I have always been using the command you mentioned)


#9

Hey all, I’ve been looking at this issue on github,

https://github.com/driftyco/ionic2/issues/775#issuecomment-166687358

I have not been able to recreate the issue.
Would you be able to comment on the issue there?


#10

Everything work find with Android 5. I thing the problem is “ionic run android” don’t works on Android 4.2.2 and earlier.


#11

Does anyone tried Ionic View to see their app with the latest Ionic 2 framework (alpha45)?

When trying it with a Blackberry Q10, I have the white screen. If I try with Ionic 1, I can see my app. I thought it was because the ionic-platform-web-client, but I don’t know how to install it with Ionic 2. It always asks the bower tool.

When trying with the Webworks tool that comes with the BB10 and both Ionic 1 and 2 app, I can see my app working perfectly!

Not sure to understand why Ionic view does not work anymore… I also asked someone with an iphone to use my app through Ionic view and it is still a white screen. :frowning:


#12

Hi icarus, i have the same problem with alpha45. If i run my app with -l -c works, and on the browser works too. Maybe a cordova problem?


#13

I also had the problem with alpha45 and a Samsung Galaxy S4. After installing crosswalk the problem (blank screen) was solved.

Running the same app via Ionic View does not work, I get a blank screen, also on a Galaxy S5 (I did not try “ionic run android” without crosswalk on the S5). From what I’ve understood from Ionic View website, it does not use the crosswalk plugin: “…View uses the Cordova inAppBrowser plugin to launch your apps in their own separate WebView”, thus that might explain why the app works via “ionic run android” + crosswalk but not via Ionic View.


#14

same problem here with android 4.2.2, note that the app run normally in BlueStack emulator.
any solution for this problem?

thanks


#15

cordova plugin add cordova-plugin-crosswalk-webview @acodebox


#16

Hello I have the same problem.

If I want to deploy my app on a real device there is the cordova startup image and afterwards a white screen only. Everything works fine inside the browser tough. I use Android 4.3 on a Samsung Galaxy SSomething…

Installing crosswalk didn’t solve it for me.


#17

Same issue. Ionic run android is working fin on Android 5 but not with Android 4.3 (on a Samsung S3). I tried to change my cordova version to 4.2 to add and remove platform but still get a blank screen. any idea will be very welcome. It is worrying if we cannot deploy on older Android versions


#18

i have the same problem.
my phone run on android-version 4.3 and shows a white screen.
i am using the tutorial app.
on another device with android-version 5.0.2 the same code-base is showing up.
what should i do?

i am using ionic 2.0.0-beta.19 and cordova -v 6.0.0


#19

As far as i know Ionic 2 takes as Android min version the same as the Cordova min version, which i think is 4.4 atm.


#20

Using crosswalk solved the issue for me.


#21

installing crosswalk alone didn’t solved it for me.
i had to install the older android platform API 21 / API 22 for the corresponding devices.