Current working directory is not a cordova-based project again


#1

HI

I have tried and tried to get this working and i am sady completly lost now.

All prior requirements are installed, Java, Ant, and i have ran npm install -g cordova and npm install -g ionic

Howeve when i run ionic start pete blank i get the message

Update config.xml
Initialising cordova project
Current working directory is not a Cordova project.

Thank you thank you for any insight into this issue.


#2

hi @scotchegg

try to create the folder and from the folder run the commend cordova create
and tell us what message u get


#3

I manually created an empty folder in c:\phonegap\todo4. Navigated to it on command line and ran "cordova create . "

it created a new project with name HelloCordova" and id “io.cordovahellocordova” at location c:\phonegap\todo4"

Directory structure is
dir hook
dir platforms
dir plugins
dir www
config.xml


#4

ALso FYI this is my PAth Env

C:\Program Files\Java\jdk1.8.0_25\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0;C:\phonegap\node_modules\cordova\bin;C:\Program Files (x86)\Git\cmd;C:\Program Files\TortoiseSVN\bin;C:\Users\Pete\AppData\Roaming\npm;C:\Program Files (x86)\Git\bin;C:\wamp\bin\mysql\mysql5.6.17\bin;C:\Program Files\nodejs;C:\adt\ant\bin;C:\adt\adt-bundle\sdk\platform-tools;C:\adt\adt-bundle\sdk\tools;C:\HashiCorp\Vagrant\bin


#5

And running running cordova version 4
ionic version 1.2.8
npm version 1.4.28
windows 7 home premuum 64bit


#6

now u can run ionic add platform?


#7

NO not at all, sadly “ionic start todo blank” still givs the same current working directory error, if i do cordova create it works but not with ionic.

Interestingly i have created a new admin user account, logged in and setup under that account and all is ok?
I could seutp my entire windows environment now to use that i gues, bt of a pain. instead wondering what or why it would work, do i need to copy , clear old plugn setting or folders somewhere that may be corrupt?


#8

maybe try to set the folder (where u save all ur projects) permission to ur user account and try to run (git,cmd,terminal) as admin and try.


#9

NO joy

I have admin accoutn rights and own all folders, but i am not sure which you are refreing? the folder i am in on CLI when running the npm installs? Either way i have done it for all folders i can think off and it still fails.

I dont think its a permissions issue, its some assuption the ionic package is making or not clearing , reseting form an old cordova or ionic install, as when i create another user account it works fine first time for fresh installs.

So its just a real pain i need to move all my user account licenses and installs to a new account to get ionic to work.

Not impresed so far.