Crosswalk runtime required


#1

Hi,

I added crosswalk in my project and strangely when I ran the app, ionic run androdi -l, I got a popup saying that the app needs the crosswalk runtime to be installed from the app store.

This is my 3rd project with crosswalk integrated and this is the first time it has asked me to install anything. I don’t want my users to install anything from the app store except for my app.

Anyone else seen this?


#2

same problem here, any solution for this yet?


#3

No, not yet. Strangely I have another app which I started in May this year, and that app has crosswalk installed. It never asks anything to be downloaded. The new ionic apps are asking to download it even after choosing embedded option.

Right now I am not using crosswalk and using native transition plugin for removing the jerks in transition.


#4

Thanks for your info,
More strangely in my recently app, it asks to download in some devices, but some are not.
How can you improve the browser to work in pre Android 4.4 version without crosswalk?


#5

the ionicframework automatically detects the browser grade, platform and work accordingly. Till the time you are not using any advanced css or js code, which is not supported in older browsers, you don’t have to worry about it as ionic does the work for you.

if you are using some advanced css or code only then you might need crosswalk. in my app I am not using anything extra so I am ok with the stock webview in Android 4.4 below OS.


#6

I don’t know what is advance js code, just use only angular. But in my app, the scroll feature is very slow if I scroll in old browser when the ion-content store large block of text.


#7

I have the same problem with my app. The last update is asking customers to download the crosswalk runtime.

What is making this happen?

This is my build environment:

Cordova CLI: 5.4.0
Gulp version: CLI version 3.9.0
Gulp local: Local version 3.9.0
Ionic CLI Version: 1.7.12
Ionic App Lib Version: 0.6.5
OS: Windows 7 SP1
Node Version: v4.2.2


#8

We have solved it rolling back to cordova CLI 5.2.0, xwalk plugin 1.2.0 and xwalk runtime 11


#9

anyway to solve this without rolling back cordova?

also any good link to safetly roll back cordova in an exisiting project without breaking everything?


#10

did you ever find a solution @Gaurav_ch ??


#11

Unfortunately no, I did not. Even the embed option is not working. In the end I have stopped using crosswalk.


#12

sorry to hear that @gaurav_ch , hmmmm I dont want to give up yet, crosswalk solved a display bug I had when people were using android 4.3 and below that I was having… I couldnt see it on my 5.1 devices but I loaded 4.3 in an emulator and sure enough there it was. I installed crosswalk, and the problem went away.

but now i have the same issue you had… I will keep searching for the next week and see what happens. If i can’t fix it, I will do what you did and abandon crosswalk


#13

Same problem here… looks like the solution is changing to embedded mode…

If the Crosswalk runtime library is not already installed on the user’s device, it will download when the app is first run. The normal startup process of the application will be interrupted.