Could not find InAppBrowser plugin whiile using $

I can make the plugin work if I install the plugin like this “cordova plugin add org.apache.cordova.inappbrowser”

But it is downloading cordova-plugin-inappbrowser instead of org.apache.cordova.inappbrowser… Below is the message shown while installing the plugin …
Notice: org.apache.cordova.inappbrowser has been automatically converted to cordova-plugin-inappbrowser and fetched from npm. This is due to our old plugins registry shutting down.

How to install the old plugin.

I too have the save the problem, please update if you find the resolution for the problem.


I have this problem today after updating my libraries ( npm update -g cordova ionic )

the problem is apparent in version 5.40 of Cordova. When the plugin is added cordova did not update the metadata information on cordova_plugin.js file.

After installing and uninstalling libraries like crazy this was what I did:

  1. Make a complete uninstall of node.js (I was running with nodejs v5.0 and npm v3.4.0)
    This a tutorial of how to completely uninstall from Windows

You can check if all libraries are no longer in your OS by running ionic -v, cordova -v, node -v, npm -v
one command at a time in your command prompt.

  1. After that I return to install nodejs but now with the stable version (v4.2.2) using the installer from the webpage. At that time I was running nodejs with 4.2.2 and npm with 2.14.7

  2. Then I will install Cordova but now with the version 5.3.3 that was the last version before the 5.40
    npm install -g cordova@5.3.3

  3. Then install ionic npm install ionic (I have the 1.7.8 version right now)

  4. Then go back to your project and delete the platform folder in my case was MyApp/platforms/android

  5. reAdd a new platform ionic add platform android
    You can see in the command prompt that all the plugins are reainstalling again

After that I was able of running my app again with the inappbrowser plugin

So in resume this was my last environment
nodejs v4.2.2
npm v2.14.7
cordova v5.3.3
ionic 1.7.8 v

And this is what I have in my ng-cordova.js file if you still have issues about the version of the plugin

Let me know if you can resolve your problem

1 Like

hi @cabbabu . I dont know whether this is the right process or not but worked for me… In ngcordova.js

at line 8877

return {

         * Check to see if the mandatory InAppBrowser plugin is installed
         * @param
         * @return   boolean
        isInAppBrowserInstalled: function(cordovaMetadata) {
           // var inAppBrowserNames = "cordova-plugin-inappbrowser";

           // return inAppBrowserNames.some(function(name) {
                return true;

I changed the code like this…It worked for me…

@denialtorres… Thanku for ur reply… Ill work as u said…