InAppBrowser plugin installed but the app can't find it


#1

I have a project that is using oauth plugin (Facebook)… Its working for months.
Today I run ionic state clean and this command removed all of plugins.
I installed all again but when I run this at my app:

 $cordovaOauth.facebook(FACEBOOK_APP_ID, [scope]).then(function(result) {
  }, function(err) {
      alert(err);
  });

The alert on error is reporting Could not find InAppBrowser plugin.
If I run cordova plugin ls this plugin is installed.

Someone had a similar issue?


#2

Remove inappbrowser first time by
cordova plugin rm org.apache.cordova.inappbrowser

and
add again inappbrowser plugin by command line.
cd appFolderName then run in CMD:

cordova plugin add cordova-plugin-inappbrowser

For details:
http://ngcordova.com/docs/plugins/inAppBrowser/


#3

that’s because the facebook plugin has a fallback mode if the facebook app is not installed on the device -> it opens a custom inappbrowser for login.


#4

The issue is about ngCordova. The plugin name changed and ngCordova is testing for the old name.
I just opened an issue at ngCordova github.


#5

Thanks the issues solved by remove the inappbrowser plugin and re-installed


#6

I am having the same issue, when I list plugins, it is there but when I run my code on an android device I get this message in the console (from chrome remote debugger):
“Native: InAppBrowser is not installed or you are running on a browser. Falling back to window.open, all instance methods will NOT work.”

I tried removing and reinstalling like detailed above but it is still happening.

any other ideas?


#7

Were you able to solve this? I’m still running into this issue now, certainly removing and adding back the plugin didn’t work either.