Cannot start Ionic app

Hi guys,

Having a bit of trouble starting an Ionic app on my mac. I have followed the instructions on the get started page and get these errors:

[=============================] 100% 0.0s

Update config.xml
Initializing cordova project
Fetching plugin “org.apache.cordova.device” via plugin registry
Error: EACCES, open '/Users/jonhockley/.plugman/plugman.log’
at Error (native)
Unable to add plugins. Perhaps your version of Cordova is too old. Try updating (npm install -g cordova), removing this project folder, and trying again. (CLI v1.3.18)

Your system information:

OS: Mac OS X Yosemite
Node Version: v0.12.0
Cordova CLI: 4.1.2
Ionic Version: 1.0.0-rc.1
Ionic CLI Version: 1.3.18
Xcode version: Xcode 6.1.1 Build version 6A2008a
ios-sim version: 3.1.1
ios-deploy version: Not installed

Before this I couldn’t even download it, but after reading the forums, I installed this specific version of cordova which has got me this far.

Any help would be great, thanks!

Anyone with any tips? At my wit’s end with this.

have you tried updating cordova?

What command are you running that is giving you this error?

you might also look at this

1 Like

Thanks for this, following the link it does seem that my tmp/ folder on my mac has been changed to be owned by root and not my user. Is this different on your machine?

I have tried changing the permissions on this ~/tmp folder but I cannot because it says it doesn’t exist? I’m assuming it’s a symlink to somewhere else. I’ll do a bit more reading and see what I can find.

Thanks again for the link!

Wow. I finally have the tabs starter app running.

My permissions were completely and utterly all over the place. Going by what I had read I had installed npm using sudo so my user couldn’t access various things.

After trying to change permissions on the tmp folder as advised, I then got a different error when trying to use the ionic start command. It reported this time that I did not have cordova installed at all.

Then I followed the advice on this page:

This then started me on the path to changing permissions on all directories that cordova/ionic shouted about. The final one being the directory that was reported in my original post. Once I had changed the .cordova and .plugman directories to be owned by me; everything now works.

Thanks again to the guys that dropped by to help. I hope I can help someone else in the future with my experience.