Ionic Start: Unable to Add Plugin

I am trying to start a new Ionic project, and I can not get past the ionic start command. I keep running into this:

C:\Users\Zach>ionic start IonicApp blank
Creating Ionic app in folder C:\Users\Zach\IonicApp based on blank project

Downloading: https://github.com/driftyco/ionic-app-base/archive/master.zip
[=============================]  100%  0.0s

Downloading: https://github.com/driftyco/ionic-starter-blank/archive/master.zip
[=============================]  100%  0.0s

Update config.xml
Initializing cordova project.
Fetching plugin "org.apache.cordova.device" via plugin registry
Error: EPERM, open 'C:\Users\Zach\.plugman\plugman.log'
Unable to add plugins. Perhaps your version of Cordova is too old. Try updating
(npm install -g cordova), removing this project folder, and trying again.

I’ve tried uninstall both ionic and cordova, updating NPM, then installing both of them again. I’ve tried going back to v3.4 of Cordova… nothing helps. And it isn’t printing any “error” in the .plugman/plugman.log it keeps telling me to look.

Thanks in advanced…
Zach

You might need to make an empty “plugins” folder your self inside your project folder. For some reason ionic or cordova wont add plugins sometimes if the folder doesn’t exist.

Also this might be a permission error. But some people also said it was just a problem with there version of cordova. Maybe try afew versions back of cordova. Usually these things are fixed fast though because they are widespread.

I had an empty plugin folder before adding any plug-ins.
The weird thing is, I can add these two plug-ins just fine:

ionic plugin add https://github.com/driftyco/ionic-plugins-keyboard.git
ionic plugin add https://github.com/VitaliiBlagodir/cordova-plugin-datepicker

But when I try to add any of the “Normal Cordova Plugins” like this:

ionic plugin add org.apache.cordova.console
ionic plugin add org.apache.cordova.device
ionic plugin add org.apache.cordova.geolocation

I get the “error”, so it seems like a plugman problem, but I can’t figure out why…

Well, I fixed it!
Here is the solution for anyone that might come across this.

Error: EPERM, open 'C:\Users\Zach\.plugman\plugman.log'

This was the error I was getting everytime I would try to install a plug-in that required plugman. Make sure that the folder “.plugman” is not set to read-only. Some how mine got set to read-only and once I removed the “read-only” permission everything is fine and dandy.

## Heading ##
I’m having the same problem I tried your fix it didn’t work.
My plugman file was already set a log.
Any more ideas?

Coyote,

Try creating a blank cordova project, and inside of it do:

cordova plugin add …

Does it tell you to check plugman/error.log?

Thanks for the suggestion, I ran a Cordova project and it seemed to work fine.

After doing a little more snooping around. I found that my Plugman .log is indeed set to read-only!
I went to the preferences and uncheck read-only, however immediately reverts back to read-only status. How were you able to permanently change the plugman .log from read-only status?
Thanks for your help
P.S. I also tried global installation for plugman, that didn’t work either…

Oh by the way here’s a screenshot of the successful plug-in.

Alright so here is my “walk through” of what I did, simply:

  1. My plugman.log was in the .plugman folder in my User directory: C:\Users\Zach.plugman
  2. Right click on .plugman and got to Properties
  3. Two check boxes on the bottom: “Read-Only” and Hidden
  4. Unchecked Read-Only, clicked apply, then prompt came up asking me to apply to directory and sub-folders, or just to directory. Select Directory + Sub-Folders
  5. Clicked OK
  6. I also uncheck “Hidden” from the properties as well, but I don’t think that would have much effect.

Then that was it for me. You might want to try setting the Read/Write permissions of .plugman through the CLI.

Hope that helps a little more.

Thank you DDbuddy you solved my problem. it was a “read-only” property that made this problem…

Hi,

I am also getting the same error, when I tried to create the new app.

I’ve tried all these stuffs and also followed the mention steps in the below post too…

But nothing is working for me. Installed version of cordova is 4.0.0

Everything is working like Java, npm, ionic, cordova, Set the JAVA_HOME and ANT_HOME variables too. Disabled the plugman folder from the readonly mode too. But nothing is helping me out. I am trying it from the past two days.

Please help me to solve this issue as soon as possible.

Thanking You in advance.

All my the plugins work, but except for this one: cordova plugin add https://github.com/katzer/cordova-plugin-email-composer.git@0.8.2. Anyone having this issue?