[Bug] Overflow Scroll not working in Beta 12 / Beta13

I just updated to ionic Beta 12 but now the overflow-scroll=“true” of ion-content has stopped working.
The native scrolling will not work unless I “scroll” with two fingers. I can no longer scroll with just one finger as I used to.

How can I fix this? Thanks in advance

Anyone? :confused:
Any ion-content list with the overflow-scroll=“true” property will stop working, but I can’t find the problem :frowning:

Same problem here, tried upgrading to beta.12 yesterday and found out that none of my lists work anymore (I only use overflow-scroll="true" overflow-x="false"). Tried messing up with the .disable-user-behavior but nothing seems to help, so I reverted.

Tested on Moto G@ 4.4.4.

Looking into this guys

Hmm, just tried it with beta 12 on both ios and android and it seemed to work well. Can you guys provide any code?

I have the same issue on my app too.
The overflow scroll is broken unless you try to scroll with both fingers. Tested on iOS 7 iPad, and nexus 5 android 4.4.

My app is hosted on www.gasparsabater.com/EMT and there you can reproduce the issue by opening the side menu and selecting “informacion de lineas” for example, but this is happening in any “large” page.

Edit: I’ve found that if the user scrolls slowly, seems to work right with one finger.

Any news con the issue?

hey @Bonda thanks for the live demo, I finally was able to see the error

Thanks for your reply @mhartington, and for the issue opened on github.
The site is not just a demo, it is the environment where i’ve been working for several months. If it weren’t because the app is related to the transport in spain, it might be featured on your “build with ionic” blog posts!
nah, just kidding

I can confirm the same issue…

 <ion-content overflow-scroll="true">...

… is not scrolling any more when deployed to a device (Android… not sure about iOS).

We’re trying to isolate where the issue could be coming from, and so far we’re not able to reproduce in with any of our sample templates.

If you guys could produce the error in a slimed down example, we could isolate the issue faster

I will mock something up on Monday. My project was build from the side menu template, and works as expected as a website on a desktop, but fails to scroll once deployed to a device (tested only on Android as stated)

Super simple way to recreate this:

-Created new app via:

ionic start scrollTest sidemenu

-Modified “PlaylistsCtrl” Controller to be:

.controller('PlaylistsCtrl', function($scope) {
    $scope.playlists = [
      { title: 'Reggae', id: 1 },
      { title: 'Chill', id: 2 },
      { title: 'Dubstep', id: 3 },
      { title: 'Indie', id: 4 },
      { title: 'Rap', id: 5 },
      { title: 'Cowbell', id: 6 },
      { title: 'Breaks', id: 7 },
      { title: 'Jungle', id: 8 },
      { title: 'Drum & Bass', id: 9 },
      { title: 'Classics', id: 10 },
      { title: 'Blah', id: 11 },
      { title: 'Foo', id: 12 },
      { title: 'Bar', id: 13 },
      { title: 'House', id: 14 },
      { title: 'Trance', id: 15 },
      { title: 'EDM', id: 15 },
      { title: 'Country', id: 16 },
      { title: 'Rock', id: 17 }

-Set overflow-scroll to true in playlists.html:

<ion-content class="has-header" overflow-scroll="true">...

-Launch app on device:

ionic run android

… and once it starts, the init view (playlists) does not scroll…

In addition, I can confirm that you CAN scroll with 2 fingers, but not 1…

Hmm, I just tested this on an iphone 5 with ios8 and it works find so far.

I just deployed this to an iPhone 4 with iOS 6 and it did NOT scroll with 1 finger but did with 2 fingers. But as I “overscrolled” at either the top or bottom of the view, I was then able to scroll with 1 finger. Sadly, that is the only iOS test device I currently have.

Alright, so it may be specific to iphone 4, let me try and I will report back

Hmm I don’t have ios6 on an iphone 4 so I can test that version, but it works fine on ios7.

If ios6 seems to be the only issue, I wouldn’t worry too. Apple requires all apps to be built for iOS7 and above so iOS6 is a thing of the past.

No, every Android I have deployed to has this issue: Samsung S3, S4, Note 3, and Nexus 5.

I currently only have an iPhone 4 with iOS 6 to test with…

Android devices has this issue. So I can’t update to beta-12.

Alright, I made this project.

Tested it on ios7, an s3, nexus 5 and wan’t able to reproduce the error.
If you guys could clone to repo and test it out, see if you can get the error.