Archive submission failed with itunesconnect

I use OsX 10.9.5 and Xcode 6.2.

I’ve prepared an update for an App already on the store. Last week I’ve uploaded a beta version that I’ve tried with testflight, then I’ve done final corrections and I’ve prepared final version for the store. I’ve archived the App, validate using the Organizer, is all ok, but when I try to submit, I always got this error:

  • Error while processing package 535417468.itmsp
  • An exception has occurred: Java heap space

I’ve tried many times since yesterday, same result, same error…

What’s wrong? Something related to last ionic update?

I can’t tell for Xcode, as I never had this error before, but on Eclipse with Maven, this error occured when my server was taking all of the Java memory allocated.
I had to increase the RAM allocated to Maven to solve this problem or to restart the server.
Maybe you can run Xcode with memory parameters.

Hope this could help.

I’ve update my Mac to El Capitain (and last version of Xcode) and all is ok. I suppose some incompatibility with java or multitasking configuration not available on old Xcode.