App instant crashes on android device [SOLVED] cordova-plugin-googleplus


#1

Good afternoon,
I hate for my first post to be a ‘help me’, but dear God please help me! :slight_smile:
I’m working on a project which is pretty extensively built out. Decided to add a social log in option via cordova-plugin-googleplus (https://github.com/EddyVerbruggen/cordova-plugin-googleplus#4-installation-phonegap-cli--cordova-cli). Installation went fine, at least I thought. Build is successful. App runs using ionic serve, but for testing I need to see it on my device itself. I’ve used ionic run android countless times and it has always worked fine until this point. Now, the app instantly crashes. No white screen, no Logcat output, nothing. Just ‘app has stopped’.

I have tried:

  • updating cordova library and project
  • uninstalling app from device and clearing cache on device
  • clearing data while app is ‘installed’
  • rebooting phone
  • removing plugin and running ionic run android - same result.
  • removing platform via ionic platform remove android, then adding it back via ionic platform add android

There may be a few other things I missed that I’ve tried. However, at this point I would be satisfied just being able to run my project in a state before I tried to add the new plugin, so any help would be greatly appreciated! I’ve spent over 5 hours trying to solve this, and it has completely halted progress. :frowning:

Thank you,
~Jay


#2

ionic info and package.json please so we know what we are dealing with.


#3

Ionic Info:

Your system information:

Cordova CLI: 7.0.1
Ionic CLI Version: 2.2.2
Ionic App Lib Version: 2.1.7
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Linux 4.8
Node Version: v5.0.0
Xcode version: Not installed

package.json:

"dependencies": {
        "angular-qrcode": "^7.2.0",
        "angularfire": "^2.3.0",
        "cordova-android": "^6.2.3",
        "cordova-plugin-compat": "^1.1.0",
        "cordova-plugin-facebook4": "~1.7.4",
        "cordova-plugin-fcm": "^2.1.1",
        "cordova-plugin-googleplus": "^5.1.1",
        "cordova-plugin-inappbrowser": "^1.7.1",
        "cordova-plugin-velda-devicefeedback": "0.0.2",
        "gulp": "^3.5.6",
        "gulp-concat": "^2.2.0",
        "gulp-minify-css": "^0.3.0",
        "gulp-rename": "^1.2.0",
        "gulp-sass": "^2.0.4",
        "ionic-plugin-keyboard": "^2.2.1",
        "phonegap-plugin-barcodescanner": "^6.0.6"
    },
    "devDependencies": {
        "bower": "^1.3.3",
        "gulp-util": "^2.2.14",
        "shelljs": "^0.3.0"
    },
    "cordovaPlugins": [
        "cordova-plugin-whitelist",
        "cordova-plugin-statusbar",
        "cordova-plugin-console",
        "cordova-plugin-device",
        "cordova-plugin-splashscreen",
        "ionic-plugin-keyboard"
    ],
    "cordovaPlatforms": [
        "ios",
        {
            "platform": "ios",
            "version": "",
            "locator": "ios"
        }
    ],
    "cordova": {
        "plugins": {
            "cordova-plugin-fcm": {},
            "cordova-plugin-googleplus": {},
            "cordova-plugin-inappbrowser": {},
            "cordova-plugin-velda-devicefeedback": {},
            "ionic-plugin-keyboard": {},
            "phonegap-plugin-barcodescanner": {}
        },
        "platforms": [
            "android"
        ]
    }```

#4

Thanks for taking a look


#5

From what I have been able to gather, It looks as though there was a conflict with the FCMPlugin and the googleplus plugin. As I don’t really need it, I’ve removed the FCMPlugin and all is back to working. Seems as though there are some ongoing compatibility issues with certain plugins/versions of dependencies with googleplus plugin for Cordova, which I wasn’t aware of before installing.

If anyone else out there plans to use the cordova-plugin-googleplus for auth it would be a good idea to read about these possible conflicts before proceeding.

Thank you,
~J