Always appears Ionic Blank starter after build my app


#1

Hi,

After seems all my installation is correct i made an app.
All seem to be fine when ionic serve is executed.

But after tried ionic build or ionic emulate i always get the resulting app like a clean Ionic Blank Starter without nothing else.

I cannot find out where is my mistake also i tried to create even a clean tabs app, then build, but again it creates a simple Ionic Blank Starter app as results.

Can anyone guide me what i’m doing wrong o what to check?.

Thanks!.


#2

I had same issue with V2, tried all sorts but in the end forced previous version of CLI tool via mom.

Npm install -g ionic@2.0.0-beta.22

I also changed Cordova version back

Npm install -g cordova@6.0.x

That worked for me for Ionic 2, may give you a pointer


#3

Hi Graham thanks,

Downgraded but now it shows a message:

Error: Please install Android target: “android-23”

Trying to find out how to set this target… any tips?. For u was the same?.

Thanks!!.


#4

So i solved last issue with this.
android update project --subprojects --path “platforms/android” --target android-22 --library “CordovaLib”

And all is working fine BUT STILL AFTER build again Ionic Blank Starter app and not the one showed on ionic serve :unamused:

Any other ideas what is happening?.


#5

Can you compare node, npm, ionic & cordova versions (as below) and also validate that ‘javac -version’ works from the command line (eg your JAVA_HOme & Path etc are all correct)

Also are you building v1 or v2 apps?

Graham
C:\Users\graham\Documents\MobileDev\test>ionic info
WARN: ionic.config.js has been deprecated, you can remove it.

Your system information:

Cordova CLI: 6.0.0
Gulp version: CLI version 3.9.1
Gulp local: Local version 3.9.1
Ionic Version: 2.0.0-beta.3
Ionic CLI Version: 2.0.0-beta.22
Ionic App Lib Version: 2.0.0-beta.12
OS:
Node Version: v5.9.1

C:\Users\graham\Documents\MobileDev\test>cordova info
Collecting Data…

Node version: v5.9.1

Cordova version: 6.0.0

Config.xml file:

{pile of stuff removed for brevity}

C:\Users\graham\Documents\MobileDev\test>node -v
v5.9.1

C:\Users\graham\Documents\MobileDev\test>npm -v
3.7.3

C:\Users\graham\Documents\MobileDev\test>


#6

Thanks Graham,

After lots of fight i reinstall again and everything start running properly.
Thanks for your time!.