Need some help getting started with Beta 32 (Blank page problem)


I’m very new to ionic. I just installed v2 beta 32 and started a new (default) project using the tutorial on this page:

Now when I start the inic serve command, I see gulp working and a webserver is started on my localhost. The browser opens neatly but shows a blank (white) page. There’s no error or warning, nothing that points me in the right direction.

ionic info shows:
Your system information:

Cordova CLI: 6.2.0
Ionic Framework Version: 2.0.0-beta.10
Ionic CLI Version: 2.0.0-beta.32
Ionic App Lib Version: 2.0.0-beta.18
Node Version: v5.11.0

What can I do to find the problem?

What command did you use to start the project?

ionic start myApp --v2

From what you’ve provided, I have not been able to recreate the issue.

That is indeed the command I ran, except for that I also added ‘tutorial’ as a project template.
Did exactly the commands in the tutorial

ionic start FunkyApp tutorial --v2
cd FunkyApp
ionic serve

Hmm, not seeing this in my test. It loads the app without any issues.

Hmmm, sounds too easy…

I also tried without specifying a project template, which causes the system to install the tabs project, and I have the same issue

ionic start testproject --v2
cd testproject
ionic serve

leaves me with an opened browser and a blank page. I see that you’re not having the same issue, but I cannot believe that nobody else has had this problem, or can help me pinpoint the problem as there is no error message or anything else that indicates what can be wrong. By not being able to reproduce the problem doesn’t mean it’s solved. Is there anyone with a hint or clue which may help me pinpoint the problem?

Chrome doesn’t come up with an error, and the console stays empty.

Hmm, yeah I’m not sure whats happening at this point.
It could be possible that the node version is to blame?

Yah im really confused now.

Updated the Node
Same outcome…

in this case
ionic start rob tutorial --v2
cd rob
ionic serve
and a blank window without any error

I’d been struggling with this as well for a very long time and got it working just now after reading the reply to this question:

I moved the folder I’d been using up the directory tree and it worked. Hope the same goes for you.

Wow, what the hack… It totally did! I ran the app from D:/Development/GIT/FunkyIonicApp. It appears this path is too long. Moving all files up to D:/Test Made everything work like a charm… Hope the Ionic guys read along…

1 Like

I have the same issue. My app is in the path C:\Users\test\ionic_app\myApp. Which path will used for my app?. Here is my node path C:\Program Files\nodejs