"you cannot install the app on your device"


I am maintaining the development of a small app and am now faced with the task of compiling the app for deployment on the Google PlayStore with a higher target sdk.

okay, I installed a suitable sdk via Android Studio,
adjusted the sdk versions in config.xml,
signed my build result with jarsigner (there was a warning that the algorithm is considered insecure),
created the final APK with zipalign
and wanted to test it briefly on my smartphone (Pixel 6 with Android 13) - as usual.

I can install other, older, APKs, here I get the message “you cannot install the app on your device” (in German: Du kannst die App auf deinem Gerät nicht installieren).
Well - Android is not very talkative and gives no clue why. none at all. Is there a en bug in the app? Did the app fail an internal test?

How can I find out? Is there something I missed?
thanks in advance for all tips and advice

kind regards

capacitor or cordova?

have you upgraded all the dependencies before updating with a higher sdk?


I tried that before, it was a complete disaster.

this is what I get when trying to do an update marked as a patch update:

npm ERR! Could not resolve dependency:
npm ERR! peer @angular/core@"7.2.16" from @angular/http@7.2.16
npm ERR! node_modules/@angular/http
npm ERR!   @angular/http@"^7.2.16" from the root project
npm ERR!
npm ERR! Conflicting peer dependency: @angular/core@7.2.16
npm ERR! node_modules/@angular/core
npm ERR!   peer @angular/core@"7.2.16" from @angular/http@7.2.16
npm ERR!   node_modules/@angular/http
npm ERR!     @angular/http@"^7.2.16" from the root project
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

I tried --force and --legacy-peer-deps and mo build was possible.
So I tried to get in at as early a point as possible, and break it up into small chunks.
A little over 3/4 of a year ago, there was an unreleased update to Ionic 6 that compiled and installed. We wanted to be prepared.
So currently, I am a bit clueless on how to proceed.

EDIT: what is the correct way to fix all upstream dependencies? Maybe that way I could do some micro steps to get this done.

the correct way is following the upgrade procedure.
First of all if your app is a Ionic 2/3 one, upgrade to ionic 6.
Then try to fix all the packages.

You can try to use the --force flag but be careful

ok, thanks for that.

But: I still have the situation that the build process succeeds without warnings or errors but I can not install the app on a device and Android gives me no clue, why.

Is there something like an EventLog, anything at all, that allows me to not guess what went wrong by try and error but to analyze it?