Hi there help me I have this error when I decide to add Android platform


#1

Hi there help me I have this error when I decide to add Android platform

npm ERR! Windows_NT 10.0.10240
npm ERR! argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\LARUMEUR\\Desktop\\appLastSave\\node_modules\\npm\\bin\\npm-cli.js" "install" "cordova-android@~6.3.0" "--production" "--sav
e-exact"
npm ERR! node v8.9.3
npm ERR! npm  v2.15.12
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package @angular/core@5.0.1 does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer @angular/common@5.0.1 wants @angular/core@5.0.1
npm ERR! peerinvalid Peer @angular/forms@5.0.1 wants @angular/core@5.0.1
npm ERR! peerinvalid Peer @angular/http@5.0.1 wants @angular/core@5.0.1
npm ERR! peerinvalid Peer @angular/platform-browser@5.0.1 wants @angular/core@5.0.1
npm ERR! peerinvalid Peer @angular/platform-browser-dynamic@5.0.1 wants @angular/core@5.0.1
npm ERR! peerinvalid Peer @ionic-native/app-rate@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/app-version@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/camera@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/crop@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/email-composer@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/facebook@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/google-plus@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/local-notifications@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/network@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/onesignal@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/paypal@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/social-sharing@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/splash-screen@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/status-bar@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic-native/stripe@4.5.2 wants @angular/core@*
npm ERR! peerinvalid Peer @ionic/storage@2.1.3 wants @angular/core@*
npm ERR! peerinvalid Peer @ngx-translate/core@9.0.2 wants @angular/core@>=5.0.0
npm ERR! peerinvalid Peer @ngx-translate/http-loader@2.0.0 wants @angular/core@>=4.3.0
npm ERR! peerinvalid Peer ionic-gallery-modal@0.2.7 wants @angular/core@^4.1.3

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Users\LARUMEUR\Desktop\appLastSave\npm-debug.log

[ERROR] Exception:


HOW TO DO SO TO RESOLVE THIS?

My package.json

{
  "name": "bbAPP",
  "version": "0.0.1",
  "author": "Ionic Framework",
  "homepage": "http://ionicframework.com/",
  "private": true,
  "scripts": {
    "clean": "ionic-app-scripts clean",
    "build": "ionic-app-scripts build",
    "lint": "ionic-app-scripts lint",
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  },
  "dependencies": {
    "@angular/common": "5.0.1",
    "@angular/compiler": "5.0.1",
    "@angular/compiler-cli": "5.0.1",
    "@angular/core": "^5.0.1",
    "@angular/forms": "5.0.1",
    "@angular/http": "5.0.1",
    "@angular/platform-browser": "5.0.1",
    "@angular/platform-browser-dynamic": "5.0.1",
    "@ionic-native/app-rate": "^4.5.2",
    "@ionic-native/app-version": "^4.5.2",
    "@ionic-native/camera": "^4.5.2",
    "@ionic-native/core": "^4.5.2",
    "@ionic-native/crop": "^4.5.2",
    "@ionic-native/email-composer": "^4.5.2",
    "@ionic-native/facebook": "^4.5.2",
    "@ionic-native/google-plus": "^4.5.2",
    "@ionic-native/local-notifications": "^4.5.2",
    "@ionic-native/network": "^4.5.2",
    "@ionic-native/onesignal": "^4.5.2",
    "@ionic-native/paypal": "^4.5.2",
    "@ionic-native/social-sharing": "^4.5.2",
    "@ionic-native/splash-screen": "4.5.2",
    "@ionic-native/status-bar": "4.5.2",
    "@ionic-native/stripe": "^4.5.2",
    "@ionic/storage": "2.1.3",
    "@ngx-translate/core": "^9.0.2",
    "@ngx-translate/http-loader": "^2.0.0",
    "bourbon": "^4.3.4",
    "card.io.cordova.mobilesdk": "^2.1.0",
    "com.paypal.cordova.mobilesdk": "^3.5.0",
    "cordova-ios": "^4.5.4",
    "cordova-plugin-app-version": "^0.1.9",
    "cordova-plugin-apprate": "^1.3.0",
    "cordova-plugin-badge": "^0.8.5",
    "cordova-plugin-camera": "^2.4.1",
    "cordova-plugin-compat": "^1.2.0",
    "cordova-plugin-device": "^1.1.7",
    "cordova-plugin-dialogs": "^1.3.4",
    "cordova-plugin-email-composer": "^0.8.11",
    "cordova-plugin-facebook4": "^1.9.1",
    "cordova-plugin-globalization": "^1.0.8",
    "cordova-plugin-inappbrowser": "^1.7.2",
    "cordova-plugin-ionic-webview": "^1.1.16",
    "cordova-plugin-local-notification": "^0.9.0-beta.1",
    "cordova-plugin-network-information": "^1.3.4",
    "cordova-plugin-splashscreen": "^4.1.0",
    "cordova-plugin-statusbar": "^2.3.0",
    "cordova-plugin-stripe": "^1.5.3",
    "cordova-plugin-whitelist": "^1.3.3",
    "cordova-plugin-x-socialsharing": "^5.2.1",
    "es6-promise-plugin": "^4.1.1",
    "font-awesome": "4.7.0",
    "ionic-angular": "^3.9.2",
    "ionic-gallery-modal": "^0.2.7",
    "ionic-img-viewer": "^2.9.0",
    "ionic-long-press": "^1.2.0",
    "ionic-plugin-keyboard": "^2.2.1",
    "ionicons": "3.0.0",
    "moment": "^2.19.4",
    "onesignal-cordova-plugin": "^2.2.4",
    "rxjs": "^5.5.5",
    "sw-toolbox": "3.6.0",
    "time-ago-pipe": "^1.2.1",
    "woocommerce-api": "^1.4.2",
    "zone.js": "^0.8.18"
  },
  "devDependencies": {
    "@ionic/app-scripts": "^3.1.5",
    "node-bourbon": "^4.2.8",
    "ionic": "3.19.0",
    "typescript": "2.4.2"
  },
  "description": "An Ionic project",
  "cordova": {
    "plugins": {
      "cordova-plugin-device": {},
      "cordova-plugin-splashscreen": {},
      "ionic-plugin-keyboard": {},
      "cordova-plugin-email-composer": {},
      "cordova-plugin-ionic-webview": {},
      "cordova-plugin-whitelist": {},
      "com.paypal.cordova.mobilesdk": {},
      "cordova-plugin-stripe": {},
      "cordova-plugin-x-socialsharing": {},
      "cordova-plugin-apprate": {},
      "cordova-plugin-app-version": {},
      "onesignal-cordova-plugin": {},
      "cordova-plugin-statusbar": {},
      "cordova-plugin-facebook4": {
        "APP_ID": "107552436606712",
        "APP_NAME": "bodybeautiful"
      },
      "cordova-plugin-camera": {},
      "cordova-plugin-network-information": {},
      "cordova-plugin-local-notification": {}
    },
    "platforms": [
      "ios"
    ]
  },
  "config": {
    "ionic_copy": "./config/copy.config.js",
    "ionic_sass": "./config/sass.config.js"
  }
}


#2

try removing your node_modules folder and do npm i


#3

Hello please i have the same error after removing your node_modules folder and do npm i


#4

try npm install @ionic/app-scripts@latest --save-dev

then

npm install typescript


#5

Please

Hello my friend please I have the same problem after doing this installation