XCode project suddenly won't build

I’m doing my iOS build the same as I have done for weeks with no issue:

1 - $> ionic build ios // ionic CLI v1.3.16
2 - open the project in XCode (6.2)
3 - Product > Clean
4 - Product > Build

… , but suddenly I’m getting:

ld: warning: ignoring file /Users/toddrimes/Library/Developer/Xcode/DerivedData/flindr-gcdaxkjlsvwarfaqanskcjduyhgk/Build/Products/Debug-iphoneos/libCordova.a, file was built for archive which is not the architecture being linked (armv7): /Users/toddrimes/Library/Developer/Xcode/DerivedData/flindr-gcdaxkjlsvwarfaqanskcjduyhgk/Build/Products/Debug-iphoneos/libCordova.a
Undefined symbols for architecture armv7:
  "_OBJC_CLASS_$_CDVWebViewDelegate", referenced from:
      objc-class-ref in CDVInAppBrowser.o
  "_OBJC_CLASS_$_CDVInvokedUrlCommand", referenced from:
      objc-class-ref in CDVFile.o
  "_OBJC_CLASS_$_CDVPluginResult", referenced from:

I’ve tried several suggestions from Stack Overflow and nothing has worked. What can I do!?

Thank you,

when in doubt, remove the platform and re-add it - possibly update the cli

npm install -g ionic
ionic platform remove ios
ionic platform add ios
ionic build ios


Thank you, Tim - that worked.