Cant build ionic 3 project whit new xcode 10 and mac mojave

the project was working fine but since i updated the xcode10 and to mac mojaveOS just problems ,for android works fine. And i already added the flag that i saw on gibhub from cordova link but none of those are making my project run, and if i open the project on xcode it wont even open.Just crash.

ionic cordova build ios -- --buildFlag="-UseModernBuildSystem=0"

my console log (it stops here on the build )

Reading build config file:

Building for iPhone X Simulator

Building project: /Users/quanticosolutions/Desktop/myseg/mobile/platforms/ios/MyApp.xcworkspace

        Configuration: Debug
        Platform: emulator
Adding xcodebuildArg: -UseModernBuildSystem=0

User defaults from command line:
    UseModernBuildSystem = 0

Build settings from command line:
    CONFIGURATION_BUILD_DIR = /Users/quanticosolutions/Desktop/myseg/mobile/platforms/ios/build/emulator
    SDKROOT = iphonesimulator12.1
    SHARED_PRECOMPS_DIR = /Users/quanticosolutions/Desktop/myseg/mobile/platforms/ios/build/sharedpch

Build settings from configuration file '/Users/quanticosolutions/Desktop/myseg/mobile/platforms/ios/cordova/build-debug.xcconfig':
    CODE_SIGN_IDENTITY = iPhone Developer
    FRAMEWORK_SEARCH_PATHS = $(inherited) "${PODS_ROOT}/OneSignal/iOS_SDK/OneSignalSDK/Framework"
    HEADER_SEARCH_PATHS = $(inherited) "${PODS_ROOT}/Headers/Public" "${PODS_ROOT}/Headers/Public/OneSignal"
    OTHER_CFLAGS = $(inherited) -isystem "${PODS_ROOT}/Headers/Public" -isystem "${PODS_ROOT}/Headers/Public/OneSignal"
    OTHER_LDFLAGS = $(inherited) -ObjC -framework "OneSignal" -framework "SystemConfiguration" -framework "UIKit" -framework "UserNotifications"

my ionic info

cli packages: (/usr/local/lib/node_modules)

    @ionic/cli-utils  : 1.19.2
    ionic (Ionic CLI) : 3.20.0

global packages:

    cordova (Cordova CLI) : 8.0.0

local packages:

    @ionic/app-scripts : 3.0.0-201710070411
    Cordova Platforms  : android 7.1.1 browser 5.0.3 ios 4.5.4
    Ionic Framework    : ionic-angular 3.9.2


    ios-deploy : 2.0.0
    Node       : v8.11.1
    npm        : 5.6.0
    OS         : macOS
    Xcode      : Xcode 10.1 Build version 10B61

Environment Variables:

    ANDROID_HOME : not set


    backend : pro

I had a problem similar to yours when I updated mojave on my mac and within the solutions they mentioned was that there was a problem with xcode 10 so the solution to my problem was to download xcode 9 and compile again and I did not have more compilation problems

i just did that but the problem still happening, now it stops lint finished in 10.63 s

Do you have the same problem? The same error?

you could put the detail of the last report that you throw to you please as you did when starting this thread

i manage now to put it to work but now i cant run the app on ios 12 cuz i downgraded to xcode 9.4.1

Check this publication, it will help you so that Xcode 9 is compatible with 12 which is what you need:

 ionic cordova build ios --buildFlag='-UseModernBuildSystem=0'

This works for me

1 Like

the first solution i found was to downgrade to xcode 9.4.1 but now i cant run on devices with ios 12, so not the best solution ,with the new vesion had to remove ios platform and added it again, with the latest version of ios and it worked and build like this ionic cordova build ios -- --buildFlag="-UseModernBuildSystem=0"

1 Like

I ran into the same issue; I was able to get the application to build and run on mojaveOs;

First make sure that you are using the latest version of the ionic cli.
Second remove the ios platform;
Third re-add the ios platform;
build the project using the same flags that you listed above.
Note: you will more that likely need to run the following command.

cd platforms/ios/cordova && npm install ios-sim@latest

I’ve updated to ios-sim 7.0.0 and still cannot build ios with this err:

[18:41:59]  build dev finished in 10.63 s
[18:42:02]  lint finished in 2.64 s
> cordova build ios
Generating initial manifest for Ionic Deploy...
Ionic Deploy initial manifest successfully generated.
Reading build config file:
CordovaError: Promise rejected with non-error: 'ios-deploy was not found. Please download, build and install version 1.9.2 or greater from into your path, or do \'npm install -g ios-deploy\''
    at cli.catch.err (/usr/local/lib/node_modules/cordova/bin/cordova:30:15)
    at process._tickCallback (internal/process/next_tick.js:68:7)
[ERROR] An error occurred while running subprocess cordova.

        cordova build ios exited with exit code 1.

my ionic info:

ionic (Ionic CLI) : 4.10.2 (/usr/local/lib/node_modules/ionic)
Ionic Framework : ionic-angular 3.9.3
@ionic/app-scripts : 3.2.2


cordova (Cordova CLI) : 8.1.2 (cordova-lib@8.1.1)
Cordova Platforms : ios 4.5.5
Cordova Plugins : cordova-plugin-ionic 5.3.0, cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 3.1.2, (and 10 other plugins)


Android SDK Tools : 26.1.1 (/Users/mauro/Library/Android/sdk/)
ios-sim : 7.0.0
NodeJS : v10.15.0 (/usr/local/bin/node)
npm : 6.7.0
OS : macOS Mojave
Xcode : Xcode 10.1 Build version 10B61

Some help ? (thanks)

Did you complete the steps for IOS setup?

yes, but it seem that xcode is still not supported, after so many time Apple release it ?? :thinking:

I’m able to build Ionic 3 projects with xcode 10 and mac mojave? How old is the project that your trying to build?

look here:
now we can build using xcode 10 witout flags

xcode 10.1 is not working with ionic 5.0.0…linker command error
The following build commands failed:
Ld /Users/dev15/Desktop/username/ionic5/myProject/platforms/ios/build/emulator/ normal x86_64