Works well on iOS 10.2.1 but not on iOS 9.3.5


#1

I have exactly the same problem. Works well on Android devices. Works well on iOS 10.2.1 but not on iOS 9.3.5. I have tried the wkwebview plugin but nothing changed.
ionic plugin install https://github.com/driftyco/cordova-plugin-wkwebview-engine --save
In detail my ion-list with virtualScroll and *ngIf dont work. And the navigation is wierd.
I’m in production so I would be glad for any help

global packages:

@ionic/cli-utils : 1.3.0
Cordova CLI      : 7.0.1
Ionic CLI        : 3.3.0

local packages:

@ionic/app-scripts              : 1.3.7
@ionic/cli-plugin-cordova       : 1.3.0
@ionic/cli-plugin-ionic-angular : 1.3.0
Cordova Platforms               : android 6.1.2 ios 4.3.1
Ionic Framework                 : ionic-angular 3.2.1

System:

Node       : v6.9.5
OS         : Windows 10
Xcode      : not installed
ios-deploy : not installed
ios-sim    : not installed

IOS deployment works with 10.2 but not 9.3?
#2

Did you remote debug the problem on the device already? Follow these instructions here to debug the problem in Safari dev tools: https://ionic.zone/debug/remote-debug-your-app#ios Look at the console and network tabs for errors.


#3

Used Safari to debug the S4 IOS 9.3 phone.

Just received (today about an hour ago) an iPhone capable of 10.x. I want to see if the same error are occurring in 10.2.

I thought you can is safari-inspector to inspect an IOS simulated phone, but haven’t been able to get that to work. Only tried for an hour or two. Do you know if this possible to do, use safari-inspector on IOS phone simulator?


#4

I’m facing the same problem. Have you solved this issue for yourself?