webpackJsonp is not defined (And I have included the vendor.js) on Android 4.4.4

#1

Hi
This issue is driving me crazy.

I get a webpackJsonp is not defined only when I am running it on a android 4.4.4 device. It was working a month ago, but now I do not know how to make it work again. I have tried to roll back to older version of package.js (without any luck).

This is only a problem for android 4.4.4.

Here is the info from ionic:
cli packages:

@ionic/cli-utils  : 1.9.2
ionic (Ionic CLI) : 3.9.2

global packages:

Cordova CLI : 7.0.1 

local packages:

@ionic/app-scripts : 2.1.4
Cordova Platforms  : android 6.2.3 ios 4.5.0
Ionic Framework    : ionic-angular 3.6.1

System:

ios-deploy : 1.9.2 
Node       : v7.10.0
npm        : 4.2.0 
OS         : macOS Sierra
Xcode      : Xcode 8.3.3 Build version 8E3004b
WebpackJsonp missing after Ionic 3 update
Uncaught ReferenceError: webpackJsonp is not defined
#2

I found out what it was. It is the clipboard pluging which will NOT work on android 4.4.4 .

#3

Hi, I know it’s been a while since this comment, but which clipboard plugin were you using? We’re using ngx-clipboard on my team’s app and we’re facing this issue as well, so just wondering if that’s what you were using too?

#4

I was using this one

#5

Ah, that’s a different one to what we’re using. Thankfully I found what our issue was though, there was an arrow function in one of the plugins we use and apparently the older versions of Android don’t support ES6, so I took a clone of it and changed it to fix and all seems to be working well again.

#6

The same error occurred again!! But lucky I found the solution. For those who get this error please check your running code inside a cordova block.

window.cordova.plugin.foobar((parameter1) => {
    //Check this code since it will not run inside a normal browser window..
}) 

In my case I used a 3.part lib (query-string) which did not compile correctly on 4.4.4

#7

Which plugin was it?

#8

I have the same problem in Android 4.4. Did you fix this inside a plugin? Can you explain more about what was the issue?

1 Like
#9

same problem with Android 5.0 :confused: