Warning when emulating iOS


#1

I keep getting this warning when emulating iOS

2015-10-04 12:11:52.095 ios-sim[3757:81938] stderrPath: /Users/pablomartinez/MobileApps/MyApp/platforms/ios/cordova/console.log
2015-10-04 12:11:52.096 ios-sim[3757:81938] stdoutPath: /Users/pablomartinez/MobileApps/MyApp/platforms/ios/cordova/console.log
2015-10-04 12:11:52.220 ios-sim[3757:81938] [MT] DVTAssertions: Warning in /Library/Caches/com.apple.xbs/Sources/DVTFrameworks/DVTFrameworks-8208/DVTFoundation/PlugInArchitecture/PlugInManager/DVTPlugInManager.m:257
Details:  Requested but did not find extension point with identifier Xcode.DVTFoundation.DevicePlatformMapping
Object:   <DVTPlugInManager: 0x7fc84ae5fa20>
Method:   -extensionPointWithIdentifier:
Thread:   <NSThread: 0x7fc84ad01430>{number = 1, name = main}
Please file a bug at http://bugreport.apple.com with this warning message and any useful information you can provide.

I’m on Yosemite OSX 10.10.5
Xcode ver. 7.0.1
Ionic CLI ver. 1.6.5
Cordova ver. 5.1.1

EDIT: Updated to cordova 5.3.3 and didn’t fix it.

Any help would be greatly appreciated!!
Thanks!!


#2

I’m having the same problem.

Cordova CLI: 5.3.3
Gulp version: CLI version 3.9.0
Gulp local: Local version 3.9.0
Ionic Version: 1.1.0
Ionic CLI Version: 1.6.5
Ionic App Lib Version: 0.3.9
ios-deploy version: 1.4.0
ios-sim version: 3.1.1
OS: Mac OS X Yosemite
Node Version: v0.12.2
Xcode version: Xcode 7.0.1 Build version 7A1001


#3

I’m having the same problem too
Cordova CLI: 5.3.3
Ionic CLI Version: 1.6.5
ios-deploy version: 1.4.0
ios-sim version: 3.1.1
OS: Mac OS X El Capitan


#4

Okay, so after a couple hours of frustration, I managed to get it back to work.

Here are what I’ve tried

  1. Uninstall cordova
  2. Delete .cordova (hidden) directory from ~/
  3. Delete platforms/ and plugins/ directories from my ionic project
  4. npm install ios-sim -g
  5. npm install ios-deploy -g
  6. Make sure all the dependencies I have in package.json up to date
  7. npm install
  8. npm install cordova -g
  9. ionic state reset
  10. ionic emulate ios

I know there are many steps but it works for me now. Hope it helps.


"ionic emulate ios" command not starting emulator
#5

Awesome! Worked like a charm!
Thanks!


#6

Thanks @devlamson! It worked great.

Btw, I think reinstalling ios-sim should probably also work. In my case it was too old - version 3.x or something.


#7

Fixed it for me:
sudo npm update -g ios-sim


#8

It works for me, thank @martinjbaker