Use specific CLI version for project

#1

I have a 3.9.2 angular app that does not build properly with the latest Ionic CLI.
I am installing a local version for the project but need to determine which older CLI would work best.
I have tried CLI 4.0.1 with no luck.
Any suggestions on which CLI version to use?

EDIT:
I went through a selection from this list without success and ended up ‘Making’ it work with the current CLI.