Upgraded to Ionic 3


#1

Hello,

I tried to upgrade to ionic 3. Changed my package.json then executed command: npm install. Below is my package.json

{
  "name": "ionic-hello-world",
  "author": "Ionic Framework",
  "homepage": "http://ionicframework.com/",
  "private": true,
  "scripts": {
    "clean": "ionic-app-scripts clean",
    "build": "ionic-app-scripts build",
    "ionic:build": "ionic-app-scripts build",
    "ionic:serve": "ionic-app-scripts serve"
  },
  "dependencies": {
    "@angular/animations": "^4.0.0",
    "@angular/common": "4.1.0",
    "@angular/compiler": "4.1.0",
    "@angular/compiler-cli": "4.1.0",
    "@angular/core": "4.1.0",
    "@angular/forms": "4.1.0",
    "@angular/http": "4.1.0",
    "@angular/platform-browser": "4.1.0",
    "@angular/platform-browser-dynamic": "4.1.0",
    "@ionic-native/core": "^3.7.0",
    "@ionic-native/native-page-transitions": "^3.4.4",
    "@ionic-native/native-storage": "^3.7.0",
    "@ionic-native/splash-screen": "^3.7.0",
    "@ionic-native/status-bar": "3.7.0",
    "@ionic/storage": "2.0.1",
    "ionic-angular": "3.2.0",
    "ionicons": "3.0.0",
    "rxjs": "5.1.1",
    "sw-toolbox": "3.6.0",
    "woocommerce-api": "^1.4.2",
    "zone.js": "0.8.10"
  },
  "devDependencies": {
    "@ionic/app-scripts": "1.3.7",
    "@ionic/cli-plugin-cordova": "1.0.0",
    "@ionic/cli-plugin-ionic-angular": "1.0.0",
    "typescript": "~2.2.1"
  },
  "cordovaPlugins": [
    "cordova-plugin-whitelist",
    "cordova-plugin-console",
    "cordova-plugin-statusbar",
    "cordova-plugin-device",
    "cordova-plugin-splashscreen",
    "ionic-plugin-keyboard"
  ],
  "cordovaPlatforms": [],
  "description": "ABC: An Ionic project"
}

On the command ionic cordova run android i am getting this error Error: app-scripts serve unexpectedly failed.

Please let me know how to solve this issue.

Thanks


#2

There’s a known bug in the 3.0.0 cli that sounds similar. Fixing it is one of the milestones for 3.0.1.


#3

Hi Aaron,

Thank for the help. But I have solved this issue also i have already commented on your github issue.


#4

So how did you solve it? Care to let the other forum users (and Google visitors) know?


#5

I was using ionic cordova run android --livereload -c -s which was giving me this error. But then i tried ionic cordova run android <- this one worked for me.