Updating dependencies


#1

On my app, looking the result of npm outdated i’ve this:
Package Current Wanted Latest Location
@angular/common 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/compiler 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/compiler-cli 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/core 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/forms 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/http 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/platform-browser 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/platform-browser-dynamic 2.2.1 2.2.1 2.4.6 ionic-hello-world
@angular/platform-server 2.2.1 2.2.1 2.4.6 ionic-hello-world
rxjs 5.0.0-beta.12 5.0.0-beta.12 5.1.0 ionic-hello-world
zone.js 0.6.26 0.6.26 0.7.6 ionic-hello-world

if i updated my package.json to latest 2.4.6 , 5.1.0 and 0.7.6 and running npm update i’ve this error:
npm WARN ionic-angular@2.0.0 requires a peer of @angular/common@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/compiler@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/compiler-cli@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/core@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/forms@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/http@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/platform-browser@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/platform-browser-dynamic@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of @angular/platform-server@2.2.1 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of rxjs@5.0.0-beta.12 but none was installed.
npm WARN ionic-angular@2.0.0 requires a peer of zone.js@~0.6.26 but none was installed.

But is there a new ionic-angular@2.x.x ?


#2

Yeah, don’t do this. “2.x.x” isn’t really the proper granularity to be looking at. There are changes in 2.3 that break the Ionic build, so 2.4.6 won’t work either. Stick with the exact version specifiers in the most recent changelog entry.


#3

Looks like app-scripts 1.0.1 might help you out.