Updated Xcode, ionic run --device not working


#1

Just updated Xcode, weird things happening. Xcode keeps asking that I verify my app on iOS device in Device Management (it is already). I’ve removed it and run it again, but my console is erroring with Error code 253 and saying "Unable to locate DeviceSupport directory. Trying a lot of things to fix, but no such luck yet, will keep this updated.


#2
2017-06-07 00:40:21.649 ios-deploy[1175:44552] [ !! ] Unable to locate DeviceSupport directory. This probably means you don't have Xcode installed, you will need to launch the app manually and logging output will not be shown!

Error: Error code 253 for command: ios-deploy with args: --justlaunch,--no-wifi

#3

Have you updated to the Xcode Beta 9?


#4

Currently on Version 8.3.3


#5

ionic serve -l and ionic emulate android -l work, but ionic emulate ios -l and ionic run --device (in this case an iOS device) are not working currently. However I can launch from Xcode now.


#6

Maybe the XCode command line tools are not up-to-date?

But your Ionic CLI is still on V2?


#7

Well it was, ran some updates and now I have v3 which seems to have made my problem worse. Honestly, I feel like taking this time to migrate to ionic 2 with cli 3.


#8

CLI V3 is simple to understand.
If you want to run a command like build, run or emulate, you have to add the cordova statement to your npm command.

ionic cordova run ios
ionic cordova build android
ionic cordova emulate ios
ionic cordova plugin add cordova-plugin-network

It is worth to upgrate to the latest CLI.

Read the documentation here: https://ionicframework.com/docs/cli/


#9

Pretty cool and thank you, however the error remains with this version as well. Android is working and iOS is failing, it literally started after updating Xcode. Odd.


#10

I have a similar problem after upgrading to Xcode 8.3.3

ionic emulate ios

…gives…

Error: Cannot read property ‘replace’ of undefined


#11

Yeah, I am getting the same error with the emulate ios


#12

Same problem with Xcode 8.3.3, Ionic 3.3.0, and CLI v3:
“Unable to locate DeviceSupport directory”

This is doing an ionic run ios


#13

Previously when faced with this after xcode releases, updating ios-sim and ios-deploy have fixed it for me. I haven’t installed or tested with the newest xcode, yet.


#14