Updated to iOS 4.3.1 and now have black screen after loading on simulator


#1

I recently updated my Cordova iOS from 4.1.0 to 4.3.1. After doing so, my app was able to be built fine through XCode and run with no error through the browser check, however, if I attempt to run the app through the iOS simmulator - it fails.

Once the splash screen fades away, I am left with just a black screen with no information on it. No errors appear through any of my logs and I believe that all of my plugins are up-to-date.

I attempted to Reset Content and Settings on the simulator, but that did not help.

Any ideas on where I should start looking next to try and fix?


#2

Click on Reload button at safari dev tools URL to see your logs.


#3

I tried that too. No errors are appearing in the Dev console.


#4

try with an actual device, maybe simulator issues


#5

I had this same issue on both iOS and Android, but when I pressed home, it showed the app, and when I reopened the app, or just went to multitasking, and back into it without closing, the app worked fine. This started happening after I upgraded from ionic 2 to ionic 3, and converted my pages to IonicPage, and did a lot of NPM updates to the latest versions, and removing and adding cordova plugins to the latest versions, so I don’t know where in the process of upgrading that this broke the app.

I ended up just creating a new ionic app, and importing the src directory, and re-adding my cordova plugins and other npm packages. Luckily I didn’t have that many on my app, or this would have been much more of a pain to do, but it ran very smoothly and quickly when I started from the starter base app.


#6

I have exactly the same issue on iOS 11 devices of screen blackout after first loading (press home button and click on the app icon will solved the issue), iOS9 and iOS8 don’t have the issue.

Anyone please help.

Thanks!