Unable to create new Ionic application

I have installed latest Ionic cli (5.4.13) and when I use any ionic commands like ‘ionic start …’ or ‘ionic docs’, I see the following error:
‘Error: write EPROTO 14352:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:c:\ws\deps\openssl\openssl\ssl\record\ssl3_record.c:332:
at WriteWrap.onWriteComplete [as oncomplete] (internal/stream_base_commons.js:87:16)’

I tried with and without proxy.
Did npm cache clean.
Upgraded node version to 12.13.1
Since I am on windows machine I tried to create app on both ‘cmd’ and ‘git bash’.

Can anyone help me on this?
Thanks in advance

Which version of ionic you are using?

I just started to create new Ionic application. I am following https://ionicframework.com/docs/installation/cli to install.
from the above Ionic documentations, I get error a step 2 (Start an app)

Elaborate on this, because I’m pretty convinced it’s a proxy configuration problem.

I have my company’s registry and proxy.
First I tried to create ionic app using company’s registry & proxy. It did not work

Then I tried with npm registry “https://registry.npmjs.org/” without any proxy. Still no luck