Ionic 3 client unable to start app behind proxy


#1

Hi
I’m having problems while trying to start a new ionic app from command line, using corporate proxy
I’m with linux. I’ve been able to upgrade npm, ionic, etc. to latest versions.
When I run the command, I get this

mypc:~$ node -v
v6.10.3
mypc:~$ npm -v
3.10.10
mypc:~$ ionic --version
3.2.0

I’ve set proxy for apt, for bash, etc. Then tried this

mypc:~$ PROXY=http://proxyip:1234 ionic start pruebaApp
? What starter would you like to use: blank
[INFO] Fetching app base (https://github.com/driftyco/ionic2-app-base/archive/master.tar.gz)
✖ Downloading - failed!
Error: connect ETIMEDOUT 192.30.253.113:443

tried this also (with and without sudo)

mypc:~$ set proxy=http://proxyip:1234
mypc:~$ ionic start pruebaApp

Ovbiously, I can download the pointed file through browser.
Tried also with sudo

Does anyone know which could be the problem? Or how to debug this problem to see what’s wrong
Thanks


#2

I would complain to whoever administers the proxy. It’s their job to make you not have to worry about stuff like this.


#3

I’d like to see you complaining to the proxy’s administrator that manages more than 4000 workstations and check if he disables the proxy only for you… :rage:
:sob:


#4

Same issue with Windows behind proxy too, An issue has been raised in github Ionic 3 CLI unable to start project behind proxy . No solution yet tho :disappointed: