Unable to build with --debug flag (solved)

I’m setting up Ionic on a new Windows 7 laptop, and having trouble building for Android with the --debug flag. Interestingly I can build using the --prod flag.

I’m new to Ionic so it’s very possible I’m making a silly mistake.

I’m building --debug like this:

ionic cordova build android --debug

My old Win laptop with, I believe, an identical setup, can build the same project just fine. Here’s the output of “ionic cordova build android --debug --verbose” on my old (working) laptop:


My new laptop fails the same command with:

LENOVO USER@Bivotron2 MINGW64 /d/Projects/ionic_projects/project1 (master)
$ ionic cordova build android --debug --verbose
2020-01-02T23:37:41.339Z ionic:lib Terminal info: { ci: false, shell: 'C:\\Program Files\\Git\\usr\\bin\\bash.exe', tty: false, windows: true }
2020-01-02T23:37:41.341Z ionic:lib CLI global options: { _: [ 'cordova', 'build', 'android' ], help: null, h: null, verbose: true, quiet: null, interactive: false, color: true, confirm: null, json: null, debug: true, project: null, '--': [] }
2020-01-02T23:37:41.566Z ionic:lib:project Project type from config: @ionic/angular (angular)
2020-01-02T23:37:41.566Z ionic:lib:project Project details: { configPath: 'D:\\Projects\\ionic_projects\\project1\\ionic.config.json', errors: [], context: 'app', type: 'angular' }
2020-01-02T23:37:41.570Z ionic Context: { binPath: 'C:\\Users\\LENOVO USER\\AppData\\Roaming\\npm\\node_modules\\ionic\\bin\\ionic', libPath: 'C:\\Users\\LENOVO USER\\AppData\\Roaming\\npm\\node_modules\\ionic', execPath: 'D:\\Projects\\ionic_projects\\project1', version: '5.4.13' }
2020-01-02T23:37:41.614Z ionic:lib:integrations:cordova:config Loading Cordova Config (config.xml: 'D:\\Projects\\ionic_projects\\project1\\config.xml', package.json: 'D:\\Projects\\ionic_projects\\project1\\package.json')
2020-01-02T23:37:41.641Z ionic:lib:build build options: {
  '--': [],
  engine: 'cordova',
  platform: 'android',
  project: undefined,
  verbose: false,
  configuration: undefined,
  sourcemaps: undefined,
  cordovaAssets: true,
  watch: undefined,
  type: 'angular'
2020-01-02T23:37:41.643Z ionic:lib:hooks Looking for ionic:build:before npm script.
2020-01-02T23:37:41.643Z ionic:lib:build Looking for ionic:build npm script.
> ng.cmd run app:ionic-cordova-build --platform=android
2020-01-02T23:37:42.713Z ng:analytics getGlobalAnalytics
2020-01-02T23:37:42.715Z ng:analytics Client Analytics config found: null
2020-01-02T23:37:42.715Z ng:analytics Analytics settings not found. Ignoring all analytics.
2020-01-02T23:37:42.715Z ng:analytics getSharedAnalytics
Generating ES5 bundles for differential loading...

It then freezes. Previously it would error out with a timeout, but now it just freezes there, possibly because I changed the version of Node to match the working laptop.

Interestingly the non working laptop can build with the --prod flag just fine.

ionic cordova build android --prod

Both laptops are running the same version of Windows (Win7), and Node (12.13.1). They’re different versions of Ionic though (working laptop is 5.4.9, non-working laptop is 5.4.13).

Is there anything else I should be looking for or should check?

Thanks for any help, and please let me know if I should post any other debug info.

Likely relevant.

1 Like

Thank you!! Worked.

For anyone else who comes this way, that link has the solution. Or the cliff notes version in my case was to modify the file browserslist in the root of my project directory so the entire contents were:

last 2 Chrome versions 
last 2 Safari versions

Of course you might want to save the old contents by commenting it out and/or backing up the file. But making that swap not only fixed my issue but made compile time miniscule.

Are there any disadvantages?

Only ones I can think of would be if you were trying to support ancient devices or any other browsers.