uid.IMEI not working from a week or so

I am having a weird problem from a week I am searching a lot to resolve this

My problem is uid.UUID is giving me a value but uid.IMEI is not working.

The error is
Ionic Native: tried calling Uid.IMEI, but the Uid plugin is not installed.
Install the Uid plugin: ‘ionic cordova plugin add cordova-plugin-uid’

Ionic Info:

Ionic CLI : 5.2.1 (/home/siva.kalluru/node_modules/ionic)
Ionic Framework : ionic-angular 3.9.3
@ionic/app-scripts : 3.2.1


Cordova CLI : 9.0.0 (cordova-lib@9.0.1)
Cordova Platforms : android 8.1.0
Cordova Plugins : cordova-plugin-ionic-keyboard 2.1.3, (and 20 other plugins)


cordova-res : not installed
native-run : 0.3.0


Android SDK Tools : 26.1.1 (/home/siva.kalluru/Android/Sdk)
NodeJS : v10.16.0 (/usr/bin/node)
npm : 6.9.0
OS : Linux 3.10

ionic cordova plugin list :

cordova plugin ls
com-badrit-base64 0.2.0 “Base64”
cordova-plugin-advanced-http 2.0.6 “Advanced HTTP plugin”
cordova-plugin-android-permissions 1.0.0 “Permissions”
cordova-plugin-camera 4.0.3 “Camera”
cordova-plugin-cocoapod-support 1.6.2 “Cordova CocoaPods Dependency Support”
cordova-plugin-contacts 3.0.1 “Contacts”
cordova-plugin-device 2.0.2 “Device”
cordova-plugin-dreamover-uid 1.3.0 “UID”
cordova-plugin-file 6.0.1 “File”
cordova-plugin-filepath 1.5.6 “cordova-plugin-filepath”
cordova-plugin-fingerprint-aio 1.7.0 “FingerprintAllInOne”
cordova-plugin-flurryanalytics 1.4.6 “Flurry Analytics”
cordova-plugin-ionic-keyboard 2.1.3 “cordova-plugin-ionic-keyboard”
cordova-plugin-network-information 2.0.2 “Network Information”
cordova-plugin-qrscanner 3.0.1 “QRScanner”
cordova-plugin-secure-storage 4.0.0 “SecureStorage”
cordova-plugin-sim 1.3.3 “SIM”
cordova-plugin-splashscreen 5.0.2 “Splashscreen”
cordova-plugin-statusbar 2.4.2 “StatusBar”
cordova-plugin-whitelist 1.3.3 “Whitelist”
cordova-sms-plugin 1.0.0 “Cordova SMS Plugin”
onesignal-cordova-plugin 2.7.0 “OneSignal Push Notifications”

I used

ionic cordova plugin add cordova-plugin-uid
npm install --save @ionic-native/uid@4

It was working very fine before a week

Can anyone please look into it. I need it very badly.
Thank you

Sorry my bad I was testing in onePlus 7T with android OS 10
When I try it in android studio virtual device with android 8 I am able to get both UUID and IMEI I don’t know why it is not working in real device with android OS 10 I’ll try to test it some other devices and will update

I tested with LG V30+ with OS 8 and it is also working very fine. I think the problem is only with the latest version.
Previously I got the same problem for secure storage plugin and I used

plugin and is working very fine with OS 10 also

Is there any alternate like this for uid plugin

Any updates here? I encountered same problem. I’m testing on android 10

Still not working. Please post the solution if you find any.