Ionic4 TouchId and FaceId not working

ionic4 TouchId and FaceId not working as expected. I have installed.
“cordova-plugin-touch-id”: “^3.4.0”,
@ionic-native/touch-id”: “^5.3.0”,

if (this._platform.is(‘ios’)) {

        this.touchId.isAvailable()
            .then(
                res => {
                    console.log('TouchID is available!')
                    this.touchIdLabel = "TOUCH ID";
                },
                err => {
                    console.error('TouchID is not available', err)
                    this.touchIdLabel = err;
                }
            );

}

It gives error: “Plugin_not_installed”,

It is working for ionic-3.

I also tried with other versions:

@ionic-native/touch-id”: “^5.17.1”,
“cordova-plugin-touch-id”: “^3.4.0”,

can u show us ur package.json file?

{
“name”: “TestTouchId”,
“version”: “0.0.1”,
“author”: “Ionic Framework”,
“homepage”: “https://ionicframework.com/”,
“scripts”: {
“ng”: “ng”,
“start”: “ng serve”,
“build”: “ng build”,
“test”: “ng test”,
“lint”: “ng lint”,
“e2e”: “ng e2e”
},
“private”: true,
“dependencies”: {
@angular/common”: “~8.1.2”,
@angular/core”: “~8.1.2”,
@angular/forms”: “~8.1.2”,
@angular/platform-browser”: “~8.1.2”,
@angular/platform-browser-dynamic”: “~8.1.2”,
@angular/router”: “~8.1.2”,
@ionic-native/core”: “^5.0.0”,
@ionic-native/fingerprint-aio”: “^4.20.0”,
@ionic-native/splash-screen”: “^5.0.0”,
@ionic-native/status-bar”: “^5.0.0”,
@ionic-native/touch-id”: “^5.17.1”,
@ionic/angular”: “^4.7.1”,
“cordova-ios”: “5.1.1”,
“cordova-plugin-fingerprint-aio”: “^3.0.0”,
“cordova-plugin-touch-id”: “^3.4.0”,
“core-js”: “^2.5.4”,
“rxjs”: “~6.5.1”,
“tslib”: “^1.9.0”,
“zone.js”: “~0.9.1”
},
“devDependencies”: {
@angular-devkit/architect”: “~0.801.2”,
@angular-devkit/build-angular”: “~0.801.2”,
@angular-devkit/core”: “~8.1.2”,
@angular-devkit/schematics”: “~8.1.2”,
@angular/cli”: “~8.1.2”,
@angular/compiler”: “~8.1.2”,
@angular/compiler-cli”: “~8.1.2”,
@angular/language-service”: “~8.1.2”,
@ionic/angular-toolkit”: “^2.1.1”,
@types/jasmine”: “~3.3.8”,
@types/jasminewd2”: “~2.0.3”,
@types/node”: “~8.9.4”,
“codelyzer”: “^5.0.0”,
“cordova-plugin-device”: “^2.0.2”,
“cordova-plugin-ionic-keyboard”: “^2.2.0”,
“cordova-plugin-ionic-webview”: “^4.1.3”,
“cordova-plugin-splashscreen”: “^5.0.2”,
“cordova-plugin-statusbar”: “^2.4.2”,
“cordova-plugin-whitelist”: “^1.3.3”,
“jasmine-core”: “~3.4.0”,
“jasmine-spec-reporter”: “~4.2.1”,
“karma”: “~4.1.0”,
“karma-chrome-launcher”: “~2.2.0”,
“karma-coverage-istanbul-reporter”: “~2.0.1”,
“karma-jasmine”: “~2.0.1”,
“karma-jasmine-html-reporter”: “^1.4.0”,
“protractor”: “~5.4.0”,
“ts-node”: “~7.0.0”,
“tslint”: “~5.15.0”,
“typescript”: “~3.4.3”
},
“description”: “An Ionic project”,
“cordova”: {
“plugins”: {
“cordova-plugin-whitelist”: {},
“cordova-plugin-statusbar”: {},
“cordova-plugin-device”: {},
“cordova-plugin-splashscreen”: {},
“cordova-plugin-ionic-webview”: {},
“cordova-plugin-ionic-keyboard”: {},
“cordova-plugin-touch-id”: {
“FACEID_USAGE_DESCRIPTION”: " "
},
“cordova-plugin-fingerprint-aio”: {
“FACEID_USAGE_DESCRIPTION”: " "
}
},
“platforms”: [
“ios”
]
}
}

maybe some version issue have u checked their github issues page ? for latest version

I am not able to find any info related to this.

What you can do is try to call your method in platform.ready() that will work.

source