TypeError: Invalid Version: Not installed


#1

after upgrading all of my packages, once I run gulp, this is what I am getting

TypeError: Invalid Version: Not installed
Invalid Version: Not installed (CLI v1.6.1)
'run-ionic' errored after 12 s
[10:12:30] Error in plugin 'gulp-shell'
Message:
    Command `ionic serve` failed with exit code 1

and:

Invalid Version: Not installed (CLI v1.6.1)

Your system information:

Cordova CLI: Not installed
Gulp version:  CLI version 3.9.0
Gulp local:   Local version 3.9.0
Ionic Version: 1.0.0-nightly-1299
Ionic CLI Version: 1.6.1
Ionic App Lib Version: 0.3.3
OS: Distributor ID:	Ubuntu Description:	Ubuntu 14.04.2 LTS 
Node Version: v0.12.4

what should I do ?


#2

You should install cordova.

npm install -g cordova


#3

Thanks Akibeā€¦Helped me too