Trying to install Ionic3 - showing Ionic 2?


#1

Hello, I’m trying to install the latest version of ionic (3) but after installing using the commands shown here: https://ionicframework.com/getting-started/, I’m noticing that it seems I still have version 2 when I type ‘ionic info’:

system information:

Cordova CLI: 7.0.1
Ionic CLI Version: 2.1.13
Ionic App Lib Version: 2.1.7
ios-deploy version: 1.8.4
ios-sim version: 3.0.0
OS: macOS Sierra
Node Version: v6.0.0
Xcode version: Xcode 8.3.2 Build version 8E2002

I also tried uninstalling ionic and reinstalling again. Any ideas what I might be missing? Seems it should be something very simple.


#2

It’s a bit confusing, because various parts of Ionic have different versioning (such as CLI versus framework). Speaking of “Ionic” having versions doesn’t make much sense. CLI v2 and v3 can both work with framework v2 or v3. CLI v3 has only recently been released, and although it is improving rapidly, you may run into problems, in which case 2.2.3 is a perfectly viable choice. CLI is what you get when you are installing “ionic” globally.

The framework is another story. That’s what you get locally in your package.json. v2 of that is no longer supported. You want the most recent supported version of the framework, which is 3.2.1 as I write this.

Finally, and if you’re still reading, I cannot possibly emphasize this enough, you really really want your npm environment managed by nvm. Any possible problems you may run into in terms of your build environment will become astronomically easier if you do so.


#3

I was also working on ionic 2 but after running this command ,the version is changed to 3.0.0

please refer to the following link-
I ran the command ionic v after this anf got the following result:-


I hope this helps.


#4

the command is:
I left above

npm install -g cordova ionic@beta


#5

running the command ionic info gives the following:


#6

Leave the @beta off to get the latest stable Ionic CLI version.


#7

Thanks, everyone!
I ran npm install -g cordova ionic@beta before I saw the last post suggesting to leave it off and ran it again without ‘beta’. I now see Ionic CLI: 3.1.2.

The strange part is that I had previously run ‘npm install -g cordova’ according to my terminal history, but still only saw 2.1.13. It’s as though I had to run it with @beta first to get v3 in my case. Not sure but in any case, I show the correct v3 now, thanks again.


#8

Great… it solved your problem.


#9

The ‘ionic’ is the important bit. ‘Cordova ionic’ installs 2 softwares at the same time.