Sandbox: bash(2538) deny(1) file-read-data /Users/.../ios/App/Pods/Target Support Files/Pods-App/Pods-App-frameworks.sh

I’m working on an Ionic iOS project and since I upgraded to macOS Sonoma 14.4.1 I get this error when I try to build my project in xcode 15.3.

I tried

  • cleaning the build folder
  • executing pod deintegrate, pod clean and pod install
  • upgrading cocoa pods with gem install cocoapods

If I set User Script Sandboxing to No, the application builds, but I still get the error when I’m building the exact same commit/version on Ionic Appflow, which I have to do to publish the Application in the App Store.

I had the same issue. My problem was that i had dependecy issues, having @capacitor/ios version 6.0.0 and @capacitor/core 5.0.5. After fixing the dependency issue all work great. I hope it helps!

I have the same issue but all my capacitor dependencies are already on 6.x

There is a way to “fix” this. You can add the line ENABLE_USER_SCRIPT_SANDBOXING = no to the files ios/App/Pods/Target Support Files/Pods-App/Pods-App.debug.xcconfig and .../Pods-App.release.xcconfig. The problem with this solution is that it gets overwritten everytime you do npx cap sync.

Does anyone know how to permanently add this configuration rule via capacitor.config.ts or similar?

A real solution would be to configure input/output paths for the sandboxing but I couldn’t find out how this would be done. Any ideas?